5 Replies Latest reply: Jan 3, 2013 2:38 AM by 914816 RSS

    Cannot secure Agent - Auth Operation Failed

    914816
      I have a grid control 10.2.0.5 installed on Windows server 2003.
      I have an Oracle Database 10g Release 10.2.0.3.0 - 64bit Production on Windows server 2003 as well.
      Everything was working perfectly until one day I saw in the Grid an error "Count of targets not uploading..."
      I tried clearing the agent by stopping it and deleting all files (xml etc) and then starting it again, but no luck.
      I can't remember the exact error but I saw I needed to re secure the agent again.
      Trying to do so led to a catastrophe, because now my agent is unreachable.

      Trying to secure the agent simply gives an error:
      Securing Agent ... Failed
      Secure.log ->
      Requesting an Oracle Wallet and Agent Key from the OMS...
      2012-12-24 11:37:23,578 [main] INFO agent.SecureAgentCmd secureAgentWithOMS.359 - Performing INIT
      2012-12-24 11:37:23,609 [main] INFO agent.SecureAgentCmd secureAgentWithOMS.382 - INIT operation succeded
      2012-12-24 11:37:23,609 [main] INFO agent.SecureAgentCmd secureAgentWithOMS.390 - Performing AUTH
      2012-12-24 11:37:23,641 [main] ERROR agent.SecureAgentCmd secureAgentWithOMS.406 - AUTH operation failed: ERROR:201:Auth Operation Failed
      Failed to secure the Agent: java.lang.Exception: AUTH operation failed

      Tried unsecuring the agent:
      OMS Upload URL - http://xxx:4889/em/upload/ is locked or unavailable.
      Secure.log ->You don't have permission to access /em/upload/ on this server

      In the OMS I get the following error (I guess it's because my agent is not secured):
      ERROR eml.OMSHandshake processFailure.843 - OMSHandshake failed.(AGENT URL = xxxx )(ERROR = KEY_MISMATCH)

      I've checked emd.properties, it's OK.
      I haven't changed anything, it has worked so far (It's not a new agent).
      what went wrong?

      thanks for your help.

      Edited by: user9342784 on Dec 24, 2012 2:00 AM
        • 1. Re: Cannot secure Agent - Auth Operation Failed
          Courtney Llamas-Oracle
          Take a look at this support note, might help you step thru.
          How to Troubleshoot the 10g Grid Control Agent Secure Issues (Doc ID 731692.1)

          Specifically, check that the emd.properties are using http and correct ports (not already secure ports and https)...

          grep 'EMD_URL=\|REPOSITORY_URL\|emdWalletSrcUrl' emd.properties

          EMD_URL=http://agentmachine.domain:port/emd/main/
          REPOSITORY_URL=http://omsmachine.domain:port/em/upload
          emdWalletSrcUrl=http://omsmachine.domain:port/em/wallets/emd
          • 2. Re: Cannot secure Agent - Auth Operation Failed
            914816
            I've done all the checks from the document, all OK.
            I am using HTTPS on EMD_URL and REPOSITORY_URL.
            Why is that a problem?
            All my agents are configured that way.
            • 3. Re: Cannot secure Agent - Auth Operation Failed
              Courtney Llamas-Oracle
              If you're trying to secure the agents, you need to revert the file to http (including the right port), then issue the secure. This worked for me several times in the past. Also, in the note there's info on how to turn on verbose output, try that and get more details in the secure.log.
              • 4. Re: Cannot secure Agent - Auth Operation Failed
                914816
                I've done that. still the same error: *"Auth Operation Failed"*
                I've set EM_SECURE_VERBOSE=true

                secure.log output:
                2013-01-02 10:02:42,312 [main] INFO agent.SecureAgentCmd secureAgentWithOMS.390 - Performing AUTH
                2013-01-02 10:02:42,312 [main] DEBUG agent.SecureAgentCmd openPage.811 - Opening: http://xxxx:4889/em/genwallet
                2013-01-02 10:02:42,358 [main] DEBUG agent.SecureAgentCmd openPage.837 - Response Status Code: 200
                2013-01-02 10:02:42,358 [main] DEBUG agent.SecureAgentCmd openPage.845 - RESPONSE_STATUS header: ERROR:201:Auth Operation Failed
                2013-01-02 10:02:42,358 [main] DEBUG agent.SecureAgentCmd openPage.846 - Response body: AUTHERROR
                2013-01-02 10:02:42,358 [main] ERROR agent.SecureAgentCmd secureAgentWithOMS.406 - AUTH operation failed: ERROR:201:Auth Operation Failed
                2013-01-02 10:02:42,358 [main] ERROR agent.SecureAgentCmd main.207 - Failed to secure the Agent:
                java.lang.Exception: AUTH operation failed
                • 5. Re: Cannot secure Agent - Auth Operation Failed
                  914816
                  I got my answer from oracle (2 weeks after openning a SR).
                  The solution was a patch.

                  thank you for you time and effort.