0 Replies Latest reply: Dec 25, 2012 2:57 AM by 689442 RSS

    include file was not found

    689442
      I create a web application using spring+hibernate+struts with cxf in MyEclipse. It works fine in Tomcat.
      Then, I export it as a war file and deploy it to weblogic 12c. However, I get error:
      Compilation of JSP File '/BZWeb/index1.jsp' failed:

      index1.jsp:2:18: The include file was not found.
      <%@ include file="/common/taglibs.jsp"%>
      ^-------------------^
      index1.jsp:2:18: The include file was not found.
      <%@ include file="/common/taglibs.jsp"%>
      ^-------------------^
      index1.jsp:7:22: The include file was not found.
      <%@ include file="/common/meta.jsp"%>
      ^----------------^
      index1.jsp:7:22: The include file was not found.
      <%@ include file="/common/meta.jsp"%>
      ^----------------^
      My weblogic.xml is as follow:
      <?xml version="1.0" encoding="UTF-8"?>
      <wls:weblogic-web-app
      xmlns:wls="http://xmlns.oracle.com/weblogic/weblogic-web-app"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd http://xmlns.oracle.com/weblogic/weblogic-web-app http://xmlns.oracle.com/weblogic/weblogic-web-app/1.4/weblogic-web-app.xsd">
      <wls:weblogic-version>12.1.1.0</wls:weblogic-version>
      <wls:context-root>BZWeb</wls:context-root>
      <wls:charset-params>
      <wls:input-charset>
      <wls:resource-path>/*</wls:resource-path>
      <wls:java-charset-name>UTF-8</wls:java-charset-name>
      </wls:input-charset>
      </wls:charset-params>
      <wls:container-descriptor>
      <wls:prefer-web-inf-classes>true</wls:prefer-web-inf-classes>
      <wls:index-directory-enabled>false</wls:index-directory-enabled>
      </wls:container-descriptor>
      <wls:jsp-descriptor>
      <wls:keepgenerated>true</wls:keepgenerated>
      <wls:precompile>true</wls:precompile>
      <wls:print-nulls>false</wls:print-nulls>
      </wls:jsp-descriptor>
      </wls:weblogic-web-app>

      Is weblogic.xml wrong?