This discussion is archived
3 Replies Latest reply: Dec 29, 2012 8:44 AM by 981795 RSS

Fusion Applications  -  Post Configure  - ECSF Issue

981795 Newbie
Currently Being Moderated
Hi,

We are installing Fusion Applications 11.1.4.0.0 and during Post Configuration Phase are encountering the following error:

ECSF configuration failed. Error message: Java returned: 1] ERROR

The complete error reported:

[2012-12-26T09:19:04.968+05:30] [runProvisioning-hcm-postconfigure] [ERROR] [FAPROV-00101] [runProvisioning-hcm-postconfigure] [tid: 25] [ecid: 0000JjKsJNfFg4WFLzfP8A1Gq_P900000G,0] [arg: /u01/oracle/fusion/provisioning/provisioning-build/orchestration-build.xml:3495: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/orchestration-build.xml:3286: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/common-misc-build.xml:109: An Error Occured:  The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/base-product-family-build.xml:350: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/hcm-build.xml:1566: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/hcm-build.xml:1259: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/base-fusion-app-build.xml:168: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/search-app-build.xml:418: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/search-app-build.xml:535: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/atgpf-build.xml:2678: The following error occurred while executing this line:\n/u01/oracle/fusion/provisioning/provisioning-build/common-misc-build.xml:109: ECSF configuration failed. Error message: Java returned: 1] ERROR: /u01/oracle/fusion/provisioning/provisioning-build/orchestration-build.xml:3495: The following error occurred while executing this line:[[
/u01/oracle/fusion/provisioning/provisioning-build/orchestration-build.xml:3286: The following error occurred while executing this line:
/u01/oracle/fusion/provisioning/provisioning-build/common-misc-build.xml:109: An Error Occured: The following error occurred while executing this line:

Please let us know if anyone has encountered this issue and if not how it can debugged further ? Verified for all know issues , Pathes, Release Notes and Blogs. Please advise if anyone know how to proceed ahead ?
  • 1. Re: Fusion Applications  -  Post Configure  - ECSF Issue
    Kalyan Pasupuleti-Oracle Expert
    Currently Being Moderated
    Hi,


    Cause

    security store (policies and credentials) was configured in jps-config.xml to use an SSL-enabled LDAP. As of now Fusion Applications provisioning is not supported SSL and thats why it is failing.

    In provisioning fusion application if we enable SSL then it fails, that is why provisioning failed in this scenario.

    Solution

    Edit jps-config.xml with non SSL (change LDAPS to LDAP) and re run the provisioning.

    We didn’t support provisioning with IDM stack ‘SSL enabled’ in 11.1.1.5.1. So, while creating provisioning plan (through Flow Designer), we have to uncheck all the SSL Enabled check boxes and proceed.

    Please proceed by non-enabling SSL, this should go fine. As of now Provisioning is not supported with SSL enabled.


    Regards,
    Kal
  • 2. Re: Fusion Applications  -  Post Configure  - ECSF Issue
    981795 Newbie
    Currently Being Moderated
    Kalyan,

    Thanks for replying.

    We verified for ldaps in jps-config.xml and there was no occurence of the same. Is there anything else to look at for resolution ?

    Regards, Raj.
  • 3. Re: Fusion Applications  -  Post Configure  - ECSF Issue
    981795 Newbie
    Currently Being Moderated
    Kalyan,

    ECSF configuration is failing at the following code section in build file:

    <if>
    <os name="AIX"/>
    <then>
    <java classname="oracle.ecsf.util.ProvisioningUtil" fork="true" classpathref="ecsf.classpath" failonerror="true">
    <arg value="${temp.ecsf.config.file}"/>

    <sysproperty key="oracle.security.jps.config" value="${ecsf.jps.config}"/>
    <sysproperty key="javax.net.ssl.trustStore" value="${ecsf.ssl.truststore}"/>
    <env key="IBM_JAVA_OPTIONS" value="-Dibm.stream.nio=TRUE -Djavax.xml.stream.XMLInputFactory=com.ibm.xml.xlxp.api.stax.XMLInputFactoryImpl -Djavax.xml.stream.XMLOutputFactory=com.ibm.xml.xlxp.api.stax.XMLOutputFactoryImpl -Djavax.xml.stream.XMLEventFactory=com.ibm.xml.xlxp.api.stax.XMLEventFactoryImpl"/>

    </java>
    </then>
    <else>
    <java classname="oracle.ecsf.util.ProvisioningUtil" fork="true" classpathref="ecsf.classpath" failonerror="true">
    <arg value="${temp.ecsf.config.file}"/>
    <sysproperty key="oracle.security.jps.config" value="${ecsf.jps.config}"/>
    <sysproperty key="javax.net.ssl.trustStore" value="${ecsf.ssl.truststore}"/>
    </java>
    </else>
    </if>


    We noticed that it is referring to ssl.trustStore which is similar to what you metioned earlier. Do you think this is causing the issue ? If so how can we disable it?


    Regards, Raj.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points