2 Replies Latest reply: Jan 9, 2013 11:56 PM by 977901 RSS

    ONS is not running

    977901
      Hi all

      When I use 'ONSCTL PING' to test the ons status, it says:

      Please configure localport and remoteport directives and attempt to start ONS server again.
      ons is not running.

      The content of D:\app\11.2.0\grid\opmn\conf\ons.config is:

      localport=6100          # line added by Agent
      allowgroup=true
      usesharedinstall=true
      remoteport=6200          # line added by Agent
      nodes=rac1:6200,rac2:6200          # line added by Agent

      The content of D:\app\11.2.0\grid\opmn\conf\ons.config.rac2 is:
      localport=6100          # line added by Agent
      allowgroup=true
      usesharedinstall=true
      remoteport=6200          # line added by Agent
      nodes=rac1:6200,rac2:6200          # line added by Agent

      The configuration file is almost the same in rac1.

      But the output of 'srvctl status nodeapps' is :
      ...
      ons is enabled
      ons is running on node1:rac1
      ons is running on node2:rac2
      ...


      It confused me a lot and I really need your help.
        • 1. Re: ONS is not running
          LaserSoft
          Hi Friend,

          First setup for debugging:

          1. srvctl stop nodeapps -n node2
          2. crsctl debug log res 'ora.node2.ons:5'
          3. srvctl start nodeapps -n nodename

          Sample Configuration File :

          ons.config :

          localport=6150
          useocr=on
          allowgroup=true
          usesharedinstall=true

          Note : You do not need to have the RemortPort in the ons.conf file.

          Reconfigure ONS with different port (If not done this step previously)

          srvctl stop nodeapps -n node2
          racgons remove_config node2:<port>
          racgons add_config node2:<port>

          then start nodeapps using srvctl command

          Hope it helps...


          Thanks
          LaserSoft
          • 2. Re: ONS is not running
            977901
            Thx, so much.

            I will try it. Hope it will help.