0 Replies Latest reply: Dec 27, 2012 10:48 AM by 981919 RSS

    IPFilters not Starting on Boot

    981919
      Hey folks -

      It seems like there was an earlier thread on this last year, but it didn't get answered. I'm playing around with a Solaris 11 VM here at home, and I'm having a hell of a time getting the ipfilters service to start when the machine boots. It's gotta be something simple and silly that I'm missing, but I'm just not sure what it is.
      madhatter# svcs -xv ipfilter
      svc:/network/ipfilter:default (IP Filter)
       State: disabled since December 27, 2012 11:17:39 AM EST
      Reason: Temporarily disabled by an administrator.
         See: http://sun.com/msg/SMF-8000-1S
         See: man -M /usr/share/man -s 5 ipfilter
      Impact: 1 dependent service is not running:
              svc:/network/ipmon:default
      This seems to indicate that I did a 'svcadm disable -t ipfilter', but I never did anything like that.
      madhatter# svcs -xv ipmon
      svc:/network/ipmon:default (IPMON)
       State: offline since December 27, 2012 11:17:29 AM EST
      Reason: Service svc:/network/ipfilter:default is temporarily disabled.
         See: http://sun.com/msg/SMF-8000-GE
        Path: svc:/network/ipmon:default
                svc:/network/ipfilter:default
         See: man -M /usr/share/man -s 1M ipmon
      Impact: This service is not running.
      This says the same thing about ipfilter: temporarily disabled for some reason. And for what it's worth, the URL reported is invalid, so I can't go look that up.

      If I do:
      madhatter# svcadm enable -r ipmon
      And check:
      madhatter# svcs -xv ipmon
      svc:/network/ipmon:default (IPMON)
       State: online since December 27, 2012 11:44:22 AM EST
         See: man -M /usr/share/man -s 1M ipmon
         See: /var/svc/log/network-ipmon:default.log
      Impact: None.
      madhatter# svcs -xv ipfilter
      svc:/network/ipfilter:default (IP Filter)
       State: online since December 27, 2012 11:44:22 AM EST
         See: man -M /usr/share/man -s 5 ipfilter
         See: /var/svc/log/network-ipfilter:default.log
      Impact: None.
      I'm all good. Until I reboot it. :-(

      The log files show nothing useful.

      Any ideas or pointers?

      Thanks!

      jas