This discussion is archived
3 Replies Latest reply: Feb 15, 2013 2:39 PM by user3684747 RSS

File gateway.cfg not under $SIEBEL_ROOT\gtwysrvr\bin, why?

user878954 Newbie
Currently Being Moderated
Hi all,

I noticed that the file gateway.cfg is not under $SIEBEL_ROOT\gtwysrvr\bin. No gateway.cfg is found anywhere in my Siebel directory.

When I try to connect to the Siebel Gateway Name Server while running the Server Configuration Wizard it says: "Unable to connect to the Gateway Name Server" although the Siebel Gateway is running.

SADMIN user is already set as user for the Siebel database. So, I think the problem is the missing gateway.cfg. No idea why it wasn't installed via installation Wizard.

The version I am trying to install is 8.1.1.0 in Windows XP Professional Edition.

I would appreciate any help or even if someone can type here the content of the file gateway.cfg so I can create the file first and use it (the content) for my own installation using my own parameter values.
  • 1. Re: File gateway.cfg not under $SIEBEL_ROOT\gtwysrvr\bin, why?
    WSiebel Pro
    Currently Being Moderated
    Here is the content of gateway.cfg file:


    [InfraNameServer]
    EnableAuditTrail = FALSE

    [InfraSecMgr]
    SecAdptName = DBSecAdpt
    SecAdptMode = DB

    [DBSecAdpt]
    DBSecAdpt_SecAdptDllName = sscfsadb

    DataSourceName = ServerDataSrc
    DBSecAdpt_PropagateChange = TRUE

    [DataSources]
    ServerDataSrc = Server
    LDAPSecAdpt = LDAP

    [ServerDataSrc]
    Docked = TRUE
    ConnectString = SBA_81_DSN
    TableOwner = sea811
    DLL = sscdo90
    SqlStyle = OracleCBO
    MaxCachedCursors = 16
    MaxCachedDataSets = 16
    ReverseFillThreshold = 100
    FileSystem = C:\sba81\fs
    GatewayAddress = localhost:2320
    EnterpriseServer = SBA_81
    CurrentSQLID = %SQLID%
    MaxCursorSize = -1
    PrefetchSize = -1
    ChartServer = localhost:8001
    ChartImageFormat = png

    [LDAPSecAdpt]
    SecAdptDllName = sscfldap
    ServerName = $(FQDNName)
    Port = $(Port)
    BaseDN = $(BaseDN)
    SharedCredentialsDN = $(SharedCredentialsDN)
    UsernameAttributeType = $(UsernameAttributeType)
    PasswordAttributeType = $(PasswordAttributeType)
    CredentialsAttributeType = $(CredentialsAttributeType)
    RolesAttributeType = $(RolesAttributeType)
    SslDatabase = $(SslDatabase)
    ApplicationUser = $(ApplicationUser)
    ApplicationPassword = $(ApplicationPassword)
    HashDBPwd = $(HashDBPwd)
    PropagateChange = $(PropagateChange)
    CRC = $(CRC)
    SingleSignOn = $(SingleSignOn)
    TrustToken = $(TrustToken)
    UseAdapterUsername = $(UseAdapterUsername)
    SiebelUsernameAttributeType = $(SiebelUsernameAttributeType)


    Thanks,

    Wilson
  • 2. Re: File gateway.cfg not under $SIEBEL_ROOT\gtwysrvr\bin, why?
    user878954 Newbie
    Currently Being Moderated
    Thanks for replying my thread and really sorry for the delay of my answer. I was not at my PC all this time because of holidays.
    It is all about a new installation. I copied the content of the file gateway.cfg which I configured with my own parameter values.

    When I retried to connect to the Siebel Gateway Name Server while running the Server Configuration Wizard it says: "Unable to connect to the Gateway Name Server" although the Siebel Gateway is running, the ODBC connection with the user SADMIN, SYS, works as well. The port 2320 is listening.

    I guess the bug is the hostname change I did before I ran the Configuration Wizard for the gateway, which had the name mypc-f0fght456 (for example), so I replaced it through f0fght456 and tried to make the changes over the registry as well. I had to recreate the repository for the Oracle Enterprise Manager with the new hostname.

    I also changed the listener.ora and tnsnames.ora, the Computer name with the new hostname, but I'm still facing this issue with the Gateway Name Server, which I can not connect with according to the Wizard.

    Can someone confirm me if I'm wrong? maybe there is a way to amend this bug...
  • 3. Re: File gateway.cfg not under $SIEBEL_ROOT\gtwysrvr\bin, why?
    user3684747 Newbie
    Currently Being Moderated
    Re-Run the configuration and update the gateway parameter.

    you are saying the gateway is up, can you connect to the srvrmgr , just using -g switch?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points