This discussion is archived
1 Reply Latest reply: Dec 31, 2012 10:29 PM by susmit roy RSS

OAS Performance Problem

legatoo Explorer
Currently Being Moderated
Hi;

We have several applications on Oracle Application Server on Solaris 10.
OAS version is 10.1.3.3.0
Database version is 11.2.0.2.0

We have a performance problem.
Our database and application server resources are idle.
But the applications is slow.
Sometimes, It hasn't been logon to applications.
Why the users couldn't login the application altough servers are idle.
We are monitoring the database form EM Console. There is no problem on EM performance tab.

DATABASE SERVER
oralive->>vmstat 1
kthr memory page disk faults cpu
r b w swap free re mf pi po fr de sr m1 m1 m1 m2 in sy cs us sy id
0 5 0 85426704 13754720 148 9930 0 0 0 0 0 0 0 0 0 5789 147735 18001 32 6 62
3 5 0 85438096 13770936 796 11426 0 16 16 0 0 0 0 0 0 6976 167676 20126 37 12 52

APPLICATION SERVER
iaslive->> vmstat 1
kthr memory page disk faults cpu
r b w swap free re mf pi po fr de sr m1 m1 m1 m2 in sy cs us sy id
2 1 0 149185944 16040976 21 40 345 0 0 0 0 0 0 0 5 5371 16393 12236 53 4 43
0 0 0 149185944 16044016 82 445 8 0 0 0 0 0 0 0 0 4868 18556 12325 38 3 59

We are getting "Unclosed connection detected" and "Attempt to use a closed handle" errors our some applications.
How to detect and solve these connection problems?

I know that very complex problem.
But we must solve the problem.

Best Regards,
Yilmaz.

Edited by: user5147211 on 31.Ara.2012 00:54

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points