2 Replies Latest reply: Jan 3, 2013 7:45 AM by ouadah RSS

    Apex Listener : Servlet error

    ouadah
      Hello,

      I have installed Apex Listener.1.0.2.238.15.24 on Oracle Containers for J2EE 10g standalone (10.1.3.1.1)

      I have got this error whn trying to cofgure listener and create connection to database

      12/12/31 14:39:27.625 apex: Servlet error
      ava.lang.IllegalAccessError: class oracle.jdbc.driver.$Proxy6 cannot access its superinterface oracle.jdbc.driver.ScrollRsetStatement
           at java.lang.reflect.Proxy.defineClass0(Native Method)
           at java.lang.reflect.Proxy.getProxyClass(Proxy.java:504)
           at java.lang.reflect.Proxy.newProxyInstance(Proxy.java:581)
           at oracle.ucp.jdbc.proxy.CallableStatementProxyFactory.createCallableStatementProxy(CallableStatementProxyFactory.java:64)
           at oracle.ucp.jdbc.proxy.ConnectionProxyFactory.proxyInvokeAfterTargetInvoke(ConnectionProxyFactory.java:154)
           at oracle.ucp.jdbc.proxy.JDBCConnectionProxyFactory.invoke(JDBCConnectionProxyFactory.java:266)
           at $Proxy0.prepareCall(Unknown Source)
           at oracle.dbtools.apex.OWA.getStatement(OWA.java:425)
           at oracle.dbtools.apex.OWA.resetSession(OWA.java:181)
           at oracle.dbtools.apex.ModApex.close(ModApex.java:143)
           at oracle.dbtools.apex.ModApex.doGet(ModApex.java:88)
           at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
           at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
           at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.1) ].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:712)
           at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.1) ].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:369)
           at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.1) ].server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:865)
           at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.1) ].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:447)
           at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.1) ].server.http.HttpRequestHandler.serveOneRequest(HttpRequestHandler.java:215)
           at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.1) ].server.http.HttpRequestHandler.run(HttpRequestHandler.java:117)
           at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.1) ].server.http.HttpRequestHandler.run(HttpRequestHandler.java:110)
           at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)
           at oracle.oc4j.network.ServerSocketAcceptHandler.procClientSocket(ServerSocketAcceptHandler.java:239)
           at oracle.oc4j.network.ServerSocketAcceptHandler.access$700(ServerSocketAcceptHandler.java:34)
           at oracle.oc4j.network.ServerSocketAcceptHandler$AcceptHandlerHorse.run(ServerSocketAcceptHandler.java:880)
           at com.evermind[Oracle Containers for J2EE 10g (10.1.3.1.1) ].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:298)
           at java.lang.Thread.run(Thread.java:619)

      Any idea ???
        • 1. Re: Apex Listener : Servlet error
          Udo
          Hello,

          sorry for the late reply.
          I have installed Apex Listener.1.0.2.238.15.24 on Oracle Containers for J2EE 10g standalone (10.1.3.1.1)
          That's a pretty old version of OC4J, and a pretty old one of APEX Listener, too. Is there any reason for not choosing a more recent release?
          Despite that, your OC4J might also be using an unsupported (and outdated) Java version. APEX Listener needs at least a JDK 1.6 Update 20.
          Please check whether your OC4J is using an appropriate JDK.

          -Udo
          • 2. Re: Apex Listener : Servlet error
            ouadah
            I am using :
            java version "1.6.0_10-beta"
            Java(TM) SE Runtime Environment (build 1.6.0_10-beta-b25)

            When i try to create a database connection (http://127.0.0.1:8888/apex/listenerAdmin) i have got this error :

            Une exception est survenue lors de l'obtention de la connexion: oracle.ucp.UniversalConnectionPoolException: Impossible d'obtenir la connexion à partir de la source de données

            Then i have downoald a new version of OC4J, and it works correctly.

            Thanx.

            Edited by: ouadah on Jan 3, 2013 2:44 PM