2 Replies Latest reply on Jan 17, 2013 4:35 PM by POPS.

    No Waitfor statement

    982365
      Hi,

      I am using OATS. I have been performing record and playback actions.

      While performing Record, I found that WaitForPage statement is not listed in OpenScript work space when the pages are navigated during recording. All the recording actions performed come under a single step group without any new step group being created.

      To brief, when I navigate from a page during recording, a WaitForPage is not created but it should be created by default. WaitForPage is necessary for us to add additional test cases that needs to be performed.

      To fix this issue, I tried re-installing OATS, modified the settings like page timeout, threshold, web-functional options and also tried restoring the setting to default values. But with no luck.

      Please help me in fixing the issues. Is there any setting which I am missing or suppose to do?

      Thanks,
      Karthikeyan

      Edited by: 979362 on Jan 1, 2013 10:00 PM
        • 1. Re: No Waitfor statement
          Gunjan Ahuja
          Hi

          Please try to update step groups by opening that script and click on "Update Step Groups" option by right click on the script name displaying above "initialize" step. You can mention the step to re-created by gap of any number of seconds you mentioned.

          See if this resolve your problem


          Thanks
          Gunjan
          • 2. Re: No Waitfor statement
            POPS.
            Hi Karthikeyan,

            Go to View->OpenScript Preferences->Record->Web Functional->General tab

            Enable Record "waitForPage" actions check box and click on OK

            Now try to record the script.

            Thank
            -POPS