This discussion is archived
1 Reply Latest reply: Jan 3, 2013 10:25 AM by Andreas Weiden RSS


newbi_egy Explorer
Currently Being Moderated
db and dev 10g rel2 ,
hi all,
i am facing the error of ora-06502 when trying to clear_block "my_block" ,
- i've a button to insert data into my table , but before the data is inserted it clears the block , so
i am writing my code like so :
clear_block('test') ; and tried it like so too "go_block('test') ; clear_block ;
end ;
but nothing happens , even my code in the button is not executed , and the error 06502 appears ?
why am i facing this error , and my code is not executed ?
i've tried clear_form too , but vainly , the same happens .
thanks in advance

Edited by: semsem on Jan 3, 2013 1:58 AM
  • 1. Re: clear_block
    Andreas Weiden Guru
    Currently Being Moderated
    CLEAR_BLOCK doesn't take the block-name as parameter. You have to use GO_BLOCK('my_block'); and then issue a CLEAR_BLOCK;

    If the error still exists you may check if it comes from the CLEAR_BLOCK or any other code in your trigger.


  • Correct Answers - 10 points
  • Helpful Answers - 5 points