This discussion is archived
1 Reply Latest reply: Jan 3, 2013 11:01 AM by CyberNinja RSS

Unable to set LDAPS first connection

dubis Newbie
Currently Being Moderated
Hello,

We use the LDAPS identification technology with OPENDS. That's working on all server (Linux and SOLARIS10), but we noted SOLARIS10 uses a LDAP first connection for loading the profile, and it uses LDAPS protocol after this step.

How to SOLARIS 10 uses LDAPS in the first step of the connection without using this LDAP connection. The solution must close the LDAP TCP port on the OpenDS server, definitively.

Thanks for your help
Regards,
  • 1. Re: Unable to set LDAPS first connection
    CyberNinja Newbie
    Currently Being Moderated
    Solaris is a pain to get working with LDAP. Look at the man page for the ldapclient command. You also need to add some items into the directory server, like schemas.

    here is an example from my test server
    # ldapclient list
    NS_LDAP_FILE_VERSION= 2.0
    NS_LDAP_BINDDN= uid=proxyagent,ou=People,dc=deathnote,dc=net
    NS_LDAP_BINDPASSWD= {NS1}ecfa88f3a945c411
    NS_LDAP_SERVERS= 10.0.1.21:389
    NS_LDAP_SEARCH_BASEDN= dc=deathnote,dc=net
    NS_LDAP_AUTH= none
    NS_LDAP_CACHETTL= 0
    NS_LDAP_CREDENTIAL_LEVEL= proxy
    NS_LDAP_SERVICE_SEARCH_DESC= passwd:ou=People,dc=deathnote,dc=net
    NS_LDAP_SERVICE_SEARCH_DESC= shadow:ou=People,dc=deathnote,dc=net
    NS_LDAP_SERVICE_SEARCH_DESC= group:ou=People,dc=deathnote,dc=net
    NS_LDAP_SERVICE_AUTH_METHOD= pam_ldap:simple

    Edited by: CyberNinja on Jan 3, 2013 1:57 PM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points