4 Replies Latest reply: Jan 15, 2013 1:32 PM by 984793 RSS

    Java 7 update 10 not working with Internet Explorer 8

    982768
      Hi there,

      I recently upgraded to Java 7 update 10 and ever since no Java applet loads in Internet Explorer 8 (works fine in Firefox 17.1).

      I've tried uninstalling Java and reinstalling Java many times, makes no difference.

      Can someone help me please?

      Thanks


      Ninko

      P.S. I'm running Windows Vista Home Premium (all updated), in case it helps.

      Edited by: 979765 on 03-Jan-2013 17:21

      Edited by: 979765 on 03-Jan-2013 17:21
        • 1. Re: Java 7 update 10 not working with Internet Explorer 8
          gimbal2
          Weird - most people have trouble running update 10 under Firefox as a matter of fact. How did you install it? Through java.com? Which version of internet explorer are you running? The 32 bits or 64 bits version?
          • 2. Re: Java 7 update 10 not working with Internet Explorer 8
            982768
            Hi gimbal2,

            I installed it through java.com, and I'm using the 32bit version.

            Thanks


            Ninko
            • 3. Re: Java 7 update 10 not working with Internet Explorer 8
              985018
              Curious to know: fire up a registry editor and check the following values are all set to 1 :

              HKLM\SOFTWARE\JavaSoft\Java Plug-In\10.11.2\UseJava2IExplorer (keys might be different in version since I'm using Update 11)
              HKLM\SOFTWARE\JavaSoft\Java Plug-In\10.11.2\UseNewJavaPlugin (keys might be different in version since I'm using Update 11)
              HKLM\SOFTWARE\JavaSoft\Java Runtime Environment\1.7.0_10\MSI\IEXPLORER

              Did you also make sure the plug-in is not disabled by the browser itself?
              • 4. Re: Java 7 update 10 not working with Internet Explorer 8
                984793
                I agree - check to make sure IE itself hasn't disabled Java.

                Since you're using Java 7.10, please also check the Security tab in the Java Control Panel which can be found in the Windows Control Panel.
                While in the Java Control Panel, check also the Advanced tab and make sure Microsoft Internet Explorer is checked under 'Default Java for browsers'

                Alternatively check this registry key: HKCU\Software\AppDataLow\Software\JavaSoft\DeploymentProperties
                For this setting: deployment.webjava.enabled
                Make sure its set to 'true' to enable java; if its 'false' it disables java.