3 Replies Latest reply: Jan 3, 2013 10:53 PM by 951325 RSS

    Weblogic Connection refused

    ManivelJaya
      Hi All,


      I am got below message daily in my web logic server.how to rectify this?.

      *'Connection refused'*

      Kindly help me.


      Thanks & Regards,
      J Manivel
        • 1. Re: Weblogic Connection refused
          951325
          Hi Manivel,

          If many connections are dropped or refused at the client, and no other error messages are on the server, the Accept Backlog value might be set too low.

          If you are getting “connection refused” messages when you try to access WebLogic Server, raise the Accept Backlog value from the default by 25 percent. Continue increasing the value by 25 percent until the messages cease to appear.

          Check out the below link for more details:


          http://docs.oracle.com/cd/E15586_01/apirefs.1111/e13952/taskhelp/tuning/TuneConnectionBacklogBuffering.html
          • 2. Re: Weblogic Connection refused
            ManivelJaya
            Hi,

            thanks for quick reply,

            can you explain what is the maximum value for accept backlog in Windows and Linux servers?.


            Regards,
            J Manivel
            • 3. Re: Weblogic Connection refused
              951325
              AcceptBacklog parameter

              You can tune the number of connection requests that a WebLogic Server instance will accept before refusing additional requests.

              This parameter specifies how many TCP connections can be buffered in a wait queue.

              This fixed-size queue is populated with requests for connections that the TCP stack has received, but the application has not accepted yet.

              By Any chance if you are getting “connection refused” messages when accessing WLS, raise the Accept Backlog by 25% until error disappears.

              Cheers