0 Replies Latest reply on Jan 4, 2013 10:23 AM by 707305

    ORA-01460 error with APEX 4.2.1

    707305
      I’ve tried the upgrade from Apex 4.0 to 4.2.1 and all seemed to be ok.

      But then, testing application I had some ORA-01460 errors.

      APEX is running on dedicated 11.2 server, but the application need to retrive data from an old financial application based on db 8.1.7 and from an erp application based on db 10.2.
      To do this, on APEX db we have some views using, via dblink, views defined on target servers.

      The error rises executing query on the 8.1.7 db if the query uses APEX shared items.

      As example:
      The application has to work for different companies of the group: when the user logs in, he must choose which company to work for; this information (2 char code) is stored in a shared item (APPL_COMPANY).

      When I go to exec the query:

      select a,b,c from myview where company = :APPL_COMPANY

      I have the error if the target db is the old one (on 10.2 I had no errors, at the moment).

      But if I try to modify the APEX query:

      select a,b,c from myview where company = ‘XX’

      all is ok.

      And, obviously, all is ok using APEX 4.0.

      So, can you suggest some workaround for this problem?

      Regards