2 Replies Latest reply: Jan 7, 2013 1:14 AM by User415813 RSS

    class oracle.cabo.ui.beans.form.RadioGroupBean has been deprecated

    User415813
      Hi all,

      im new to OAF just going through basics,n need u OAF champs help...
      here is my code...

      OAMessageChoiceBean oaCollectorBean = (OAMessageChoiceBean)pgbean.findChildRecursive("prCollector");
      OAMessageRadioGroupBean oaReviewCycleBean = (OAMessageRadioGroupBean)pgbean.findChildRecursive("RevCycle");
      OAMessageChoiceBean oaCreditAnalystBean = (OAMessageChoiceBean)pgbean.findChildRecursive("CreditAnalyst");

      if ("CREDIT".equalsIgnoreCase(strCategory))
      {              
      if(!(null == oaCollectorBean ))
      {
      oaCollectorBean.setRequired("yes");
      }
      if(!(null== oaReviewCycleBean) )
      {
      oaReviewCycleBean.setRequired("yes");
      }
      if(!(null == oaCreditAnalystBean))
      {
      oaCreditAnalystBean.setRequired("yes");
      }
      }
      else
      {
      oaCollectorBean.setRequired("no");
      oaReviewCycleBean.setRequired("no");
      oaCreditAnalystBean.setRequired("no");
      }

      here im getting warnings as

      Warning(44,37): class oracle.cabo.ui.beans.form.RadioGroupBean has been deprecated

      may be beacause of which my beans are not getting mandatory...

      please help.


      Thanks'
      Namrata
        • 1. Re: class oracle.cabo.ui.beans.form.RadioGroupBean has been deprecated
          Sushant Sharma
          Hi,

          Instead of importing oracle.cabo.ui.beans.form.RadioGroupBean, try by importing this class:
          oracle.apps.fnd.framework.webui.beans.message.OAMessageRadioGroupBean

          --Sushant                                                                                                                                                                                                                                                                                                                                                                           
          • 2. Re: class oracle.cabo.ui.beans.form.RadioGroupBean has been deprecated
            User415813
            Hi Sushant,
            tried your solution, still getting same error...


            Namrata