4 Replies Latest reply: Jan 6, 2013 11:49 PM by Krishna-Oracle RSS

    error installing oracle 9i on linux 5

    983153
      i've got error.
      when i install oracle 9i R2 32bit on RHEL 5
      it is this one

      Initializing Java Virtual Machine from /tmp/OraInstall/tmp/OraInstall2013-01-06_11-42-12PM/jre/bin/i386/native_threads/java: error while loading shared libraries: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory

      i don't know this happen
      i've installed rpm
      libXp-devel-1.0.0-8.1.el5.i386.rpm
      libXp-1.0.0-8.1.el5.i386.rpm
      compat-oracle-rhel4-1.0-5.i386.rpm
      compat-libcwait-2.1-1.i386.rpm

      how can i do it..

      Edited by: 980150 on 2013. 1. 6 오전 7:01
        • 1. Re: error installing oracle 9i on linux 5
          Srini Chavali-Oracle
          AFAIK, 9.2.0.1 was never certified with Linux 5.x - http://docs.oracle.com/html/A96167_01/pre.htm#sthref106

          Is there a reason you are using a desupported version of Oracle ?

          HTH
          Srini
          • 2. Re: error installing oracle 9i on linux 5
            Paul M.
            oracle 9i R2 32bit on RHEL 5
            Which exact version of RHEL 5 ? Some years ago I did install 9iR2 on Linux 5
            SQL> select * from v$version;
            
            BANNER
            ----------------------------------------------------------------
            Oracle9i Enterprise Edition Release 9.2.0.4.0 - Production
            PL/SQL Release 9.2.0.4.0 - Production
            CORE    9.2.0.3.0       Production
            TNS for Linux: Version 9.2.0.4.0 - Production
            NLSRTL Version 9.2.0.4.0 - Production
            
            SQL> !cat /etc/redhat-release
            Enterprise Linux Enterprise Linux Server release 5 (Carthage)
            
            SQL> 
            but I've never been able to do the same on 5.2 onwards.
            • 3. Re: error installing oracle 9i on linux 5
              983153
              i did it
              like that
              #vi /etc/redhat-release
              Red Hat Enterprise Linux Server Release 5.3
              changed
              Red Hat Enterprise LInux Server Release 4

              changed Linux version..
              but
              i could not solve the problem

              i think...
              i need rpm..libstdc++_libc6.1-1.so.2
              this one i can't find it
              my E-mail address : jykil0918@nate.com
              if you know this problem
              help me please...

              Edited by: 980150 on 2013. 1. 6 오후 9:33
              • 4. Re: error installing oracle 9i on linux 5
                Krishna-Oracle
                Hi,
                Red Hat Enterprise 5 requires minimum 10.2.0.3 or higher

                9iR2 is not supported on RHEL 5
                Kindly refer below document
                Certification Information for Oracle Database on Linux x86 (Doc ID 1307056.1)


                Thanks,
                Krishna

                Edited by: 858118 on Jan 6, 2013 9:49 PM