This discussion is archived
9 Replies Latest reply: Jan 25, 2013 11:42 PM by asahide RSS

Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?

georgehorlacher Newbie
Currently Being Moderated
I've got Oracle 6.3 with this kernel installed and 'acfsroot install' fails the kernel version check ( ADVM/ACFS is not supported on this OS version )

Patch 14275572 only has the 2.6.32-300-x86_64 version for files:
oracleacfs.ko oracleadvm.ko oracleoks.ko

How do I get the version for the kernel I'm running?

If there is no way to add updated modules, whats the standard procedure for going back to 2.6.32-300 kernel?
(Then I hope to run 'acfsroot install' and have it supported)

How come this happens? (I just installed the latest Oracle Linux 6.3 and latest 11.2.0.3 and it doesnt work?)

Thanks for any help.
  • 1. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    asahide Expert
    Currently Being Moderated
    Hi,

    Check this Note(1369107.1).
    <<https://support.oracle.com/CSP/main/article?cmd=show&type=NOT&id=1369107.1>>

    Regards,
  • 2. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    georgehorlacher Newbie
    Currently Being Moderated
    Thanks for the doc, I've read through this doc already and it helped a lot to understand the problem.

    From what I can tell I need to boot from a previous kernel (2.6.*32*-300) to run the install. (Still don't see any 2.6.*39*-300 versions in patches)

    How do I accomplish this? Will it break anything by doing this? I don't know how to get a hold of the previous kernel version that have support for ACM and apply them.

    Do I have to sign up with unbreakable linux and get it from there instead of just using Oracle Linux 6.3 with the Oracle channel?

    Frustrating that there is not a version that works with the latest kernel that you get from a vanilla install...
  • 3. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    asahide Expert
    Currently Being Moderated
    Hi,

    How about follows,
    #uname -a
    #lsmod | grep oracle
    #rpm -qa | grep oracle
  • 4. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    Dude! Guru
    Currently Being Moderated
    Please do not confuse ADVM/ACFS with oracleasm. The oracleasm kernel driver is built-in with the UEK kernel, but the necessary kernel driver to support the ADVM/ACFS file system is provided by the Oracle database installation. For compatibility with Oracle Linux 6 kernel versions you need to install 11.2.0.3. If you update the kernel, you also need to update the ADVM/ACVFS driver, for which you will need access to Oracle support.

    However, for installing and setting up Oracle ASM you do not need any ADVM/ACFS kernel driver support. It is only necessary in case you want to provide a conventional OS mount point for a volume contained inside of ASM. If I remember correctly the use is not recommended.
  • 5. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    georgehorlacher Newbie
    Currently Being Moderated
    [root@oracleA patches]# uname -a
    Linux oracleA.applabs.com 2.6.39-300.17.3.el6uek.x86_64 #1 SMP Wed Dec 19 06:28:03 PST 2012 x86_64 x86_64 x86_64 GNU/Linux

    [root@oracleA patches]# lsmod |grep oracle
    oracleasm 53352 1

    [root@oracleA patches]# rpm -qa | grep oracle
    oracle-rdbms-server-11gR2-preinstall-1.0-6.el6.x86_64
    oraclelinux-release-notes-6Server-7.x86_64
    oracle-logos-60.0.11-9.el6.noarch
    oracleasm-support-2.1.5-1.el6.x86_64
    oraclelinux-release-6Server-3.0.2.x86_64
  • 6. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    georgehorlacher Newbie
    Currently Being Moderated
    Yes, the oracleasm is working properly for hosting the databases.

    What you said "conventional OS mount point for a volume contained inside of ASM." is exactly what I've been trying to get working. I want to mount some shared storage I can access for File I/O on a regular mount point. So I think I've been trying to get the right kernel modules to support that but it doesnt look like the 2.6.39 has any... The only thing I'm seeing is support in 2.6.32 which I'm not sure how to get to. When you say its not recommended, I'm wondering does it have problems doing file I/O? Sounded like just what I was looking for, a cluster supported file system.
  • 7. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    georgehorlacher Newbie
    Currently Being Moderated
    As a test I changed the boot loader in /boot/grub/grub.conf to boot to the /vmlinuz-2.6.32-279.el6.x86_64
    Then rebooted into that kernel
    Unfortunetly my cluster failed to load.
    I did run acfsroot install and that said it was successful for the 2.6.32-279 kernel
    acfsroot enable did not work though as it required the cluster to be up and running.
    I could not run asmca either as it required the cluster to be running

    So I put back the 2.6.39-300 Kernel in the boot loader, rebooted and it came up OK with the Cluster, but of course the drivers for acfs did not load.
    I don't think you can run them without a matching kernel?

    I only have those two kernels available on my system. So if there are no modules for the 2.6.39 kernel, then I guess I need to find a stable kernel that my Rac install will run OK on that can be patched to use acfs. Maybe I should try 2.6.32-300 ? Anyone know how to add previous kernels to Oracle Linux 6.3 ? And would my existing cluster work or would I have to reinstall everything?
  • 8. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    Dude! Guru
    Currently Being Moderated
    Please see the following link for answer to your last response.

    http://docs.oracle.com/cd/E11882_01/install.112/e16763/oraclerestart.htm#BGBGEDGA

    It seems Kernel 2.6.39 (UEK2, Linux kernel 3.0) is not supported and kernel 200 and later needs patches, but you can check the info on Oracle Support for details.
  • 9. Re: Is there an asm driver update for kernel 2.6.39-300.17.3.el6uek.x86_64?
    asahide Expert
    Currently Being Moderated
    Hi,

    According to 1369107.1,
    ACFS is now supported on 2.6.39 kernel by patching 12983005 for 11.2.0.3.4 (GIPSU).

    Check it..

    Rgd,

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points