1 2 Previous Next 15 Replies Latest reply: May 6, 2013 6:24 AM by Gensis2001 RSS

    Data Guard Summary problem using Grid Control.

    Gensis2001
      I setup data guard using Grid Control and after completion, the console of the standby database shows: "Unable to determine Data Guard information." under the Data Guard Summary section. The primary database is not showing the standby. I'm using Red Hat Linux Server 5.7 (64bit) and Oracle 10.2.0.5. This is a standalone (no RAC or ASM involved). When I run show configuration, the following comes up:

      DGMGRL> SHOW CONFIGURATION;

      Configuration
      Name: PRODDB_ghph@ora01
      Enabled: YES
      Protection Mode: MaxPerformance
      Fast-Start Failover: DISABLED
      Databases:
      ghph - Primary database
      gsbh - Physical standby database (disabled)

      Current status for "PRODDB_ghph@ora01":
      SUCCESS

      I tried searching online and metalink but nothing. Any help in solving this problem would be appreciated. TIA

      Edited by: Gensis2001 on Jan 8, 2013 3:08 PM
        • 1. Re: Data Guard Summary problem using Grid Control.
          mseberg
          Hello;

          Can you post how you added the Standby database to the Configuration?

          Would expect :

          DGMGRL> ENABLE DATABASE 'gsbh';

          I'm sorry Dave, I cannot configure that...

          Best Regards

          mseberg
          • 2. Re: Data Guard Summary problem using Grid Control.
            Gensis2001
            The standby was added through Grid Control. I'm in the process of retrying the whole thing. Hopefully it will work this time :)
            • 3. Re: Data Guard Summary problem using Grid Control.
              Gensis2001
              The rebuild did not completely fix the problem. I'm now seeing the data guard status as "down" on Grid Control. The primary and physical databases are up. It appears archive logs are being shipped from the primary to the standby. I also ran the enable as suggested and here is the output:

              DGMGRL> show configuration

              Configuration
              Name: PRODDB_ghph@ora01
              Enabled: YES
              Protection Mode: MaxPerformance
              Fast-Start Failover: DISABLED
              Databases:
              ghph - Primary database
              gsbh - Physical standby database (disabled)

              Current status for "PRODDB_ghph@ora01":
              SUCCESS

              DGMGRL> enable database 'gsbh';
              Enabled.
              DGMGRL> show configuration

              Configuration
              Name: PRODDB_ghph@ora01
              Enabled: YES
              Protection Mode: MaxPerformance
              Fast-Start Failover: DISABLED
              Databases:
              ghph - Primary database
              gsbh - Physical standby database

              Current status for "PRODDB_ghph@ora01":
              Warning: ORA-16607: one or more databases have failed

              Any suggestions?

              Edited by: Gensis2001 on Jan 14, 2013 9:36 AM
              • 4. Re: Data Guard Summary problem using Grid Control.
                Gensis2001
                After recreating the standby, it still shows the status and unavailable. Please not the following SQL:

                SYS@gsbh> select process, status, sequence# from v$managed_standby;

                PROCESS STATUS SEQUENCE#
                --------- ------------ ----------
                ARCH CLOSING 60259
                ARCH CLOSING 60260
                RFS IDLE 60261
                MR(fg) WAIT_FOR_GAP 58673

                4 rows selected.

                How do I fix the wait_for_gap?
                • 5. Re: Data Guard Summary problem using Grid Control.
                  mseberg
                  How long has it waited for the gap?

                  After the recreate you positive everything is enabled?

                  Best Regards

                  mseberg
                  • 6. Re: Data Guard Summary problem using Grid Control.
                    Gensis2001
                    I'm not sure how long it has been waiting but the Grid Control job to recreate the physical standby has been running since 3/18. Not sure if everything is enabled; however, I've been searching for ways to tell if the setup is finished and if not what needs to be done. Doesn't seem to be any single information with helping on that front.
                    • 7. Re: Data Guard Summary problem using Grid Control.
                      mseberg
                      Sequence number 58673

                      Standby CLOSING 60352


                      Differance 1679

                      If you have redo of 100MB you are 163GB behind.

                      Does not look like you have a standby database to me.

                      Edited by: mseberg on Jan 22, 2013 2:36 PM
                      • 8. Re: Data Guard Summary problem using Grid Control.
                        Gensis2001
                        Does this make any sense?

                        SYS@gsbh> SELECT * FROM V$ARCHIVE_GAP;

                        no rows selected

                        SYS@gsbh> select process, status, sequence# from v$managed_standby;

                        PROCESS STATUS SEQUENCE#
                        --------- ------------ ----------
                        ARCH CLOSING 60353
                        ARCH CLOSING 60352
                        RFS IDLE 60354
                        MR(fg) WAIT_FOR_GAP 58673

                        4 rows selected.
                        • 9. Re: Data Guard Summary problem using Grid Control.
                          CKPT
                          Gensis2001 wrote:
                          Does this make any sense?

                          SYS@gsbh> SELECT * FROM V$ARCHIVE_GAP;

                          no rows selected

                          SYS@gsbh> select process, status, sequence# from v$managed_standby;

                          PROCESS STATUS SEQUENCE#
                          --------- ------------ ----------
                          ARCH CLOSING 60353
                          ARCH CLOSING 60352
                          RFS IDLE 60354
                          MR(fg) WAIT_FOR_GAP 58673

                          4 rows selected.
                          Currently standby is waiting for the sequence *58673* but the later on archives of series 60353... are already archived.
                          Can you confirm that only archive sequence * 58673* is missing or any more? If you have less number of archives are missing then see how the parameters you configured. like FAL_SERVER, LOG_ARCHIVE_CONFIG, LOG_ARCHIVE_DEST_n so on.

                          Check below command and see any errors with remote destinations
                          select severity,error_code,to_char(timestamp,'DD-MON-YYYY HH24:MI:SS') "timestamp" , message from v$dataguard_status where dest_id=2;
                          Source: http://www.oracle-ckpt.com/dataguard_troubleshoot_snapper/


                          If the archives are missing so many and you do not have backup, then certainly you have to choose incremental roll forward to synchronize the primary database, then only you can see the configuration status of Broker as valid. You can refer this article to perform incremental roll forward http://www.oracle-ckpt.com/rman-incremental-backups-to-roll-forward-a-physical-standby-database-2/
                          • 10. Re: Data Guard Summary problem using Grid Control.
                            Gensis2001
                            Had some issues of running out of flash back recovery space and after solving that I get the following output:

                            SYS@gsbh> select process, status,thread#,sequence# from v$managed_standby;

                            PROCESS STATUS THREAD# SEQUENCE#
                            --------- ------------ ---------- ----------
                            ARCH CLOSING 1 60633
                            ARCH CLOSING 1 60632
                            RFS IDLE 1 60634

                            When I look at the standby in Grid Control I get the following error ORA-16541: site is not enabled. Looks like I have to start over again.
                            • 11. Re: Data Guard Summary problem using Grid Control.
                              mseberg
                              Might check these first :

                              http://myoracledbablogon.blogspot.com/2010/11/error-ora-16541-site-is-not-enabled.html

                              DGMGRL Enable Configuration Fails With ORA-16627 For Maximum-Availability-Mode [ID 294494.1]

                              Reinstating a Standby Database after Failover fails with ORA-16623 / ORA-16541 [ID 1131833.1]


                              I would also consider giving Grid the boot for Data Guard setup. Its a wrapper. Try setting it up using a power users method or RMAN duplicate. I think you will get better results.

                              Best Regards

                              mseberg

                              Edited by: mseberg on Jan 23, 2013 7:59 AM
                              • 12. Re: Data Guard Summary problem using Grid Control.
                                Gensis2001
                                If I set it up without Grid Control, will I still be able to monitor it through Grid Control?
                                • 13. Re: Data Guard Summary problem using Grid Control.
                                  mseberg
                                  I do.

                                  None of mine were setup with Grid. You may want to add some custom metrics, but it should not be an issue.

                                  http://www.visi.com/~mseberg/data_guard_on_oracle_11_step_by_step.html

                                  http://www.visi.com/~mseberg/duprman2.html

                                  Best Regards

                                  mseberg
                                  • 14. Re: Data Guard Summary problem using Grid Control.
                                    Gensis2001
                                    OK, thanks, I will look into setting it up manually.
                                    1 2 Previous Next