1 2 Previous Next 16 Replies Latest reply: Jan 14, 2013 2:56 AM by MAveri((k RSS

    Issues in installing RPMs for RHEL 6

    MAveri((k
      Dear All

      I am trying to install R12.1 on RHEL 6. As per the documentation I am getting the required RPMs Installed on my RHEL 6.

      However I am getting a lot of dependency issues and most of my RPMs are not installed.

      Perticularly I m getting issues in installation of i686 versions of RPMs.

      Here is one such error that i am getting while istallation of glibc package

      [root@ebs RPMs]# yum install glibc-2.12-1.7.el6.i686.rpm
      Loaded plugins: refresh-packagekit, rhnplugin
      This system is not registered with RHN.
      RHN support will be disabled.
      Setting up Install Process
      Examining glibc-2.12-1.7.el6.i686.rpm: glibc-2.12-1.7.el6.i686
      Marking glibc-2.12-1.7.el6.i686.rpm to be installed
      Resolving Dependencies
      --> Running transaction check
      ---> Package glibc.i686 0:2.12-1.7.el6 set to be updated
      --> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.7.el6.i686
      --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.7.el6.i686
      --> Finished Dependency Resolution
      Error: Package: glibc-2.12-1.7.el6.i686 (/glibc-2.12-1.7.el6.i686)
      Requires: libfreebl3.so(NSSRAWHASH_3.12.3)
      Error: Package: glibc-2.12-1.7.el6.i686 (/glibc-2.12-1.7.el6.i686)
      Requires: libfreebl3.so
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va nofiles nodigest


      Please help.
        • 1. Re: Issues in installing RPMs for RHEL 6
          Hussein Sawwan-Oracle
          980789 wrote:
          Dear All

          I am trying to install R12.1 on RHEL 6. As per the documentation I am getting the required RPMs Installed on my RHEL 6.

          However I am getting a lot of dependency issues and most of my RPMs are not installed.

          Perticularly I m getting issues in installation of i686 versions of RPMs.

          Here is one such error that i am getting while istallation of glibc package

          [root@ebs RPMs]# yum install glibc-2.12-1.7.el6.i686.rpm
          Loaded plugins: refresh-packagekit, rhnplugin
          This system is not registered with RHN.
          RHN support will be disabled.
          Setting up Install Process
          Examining glibc-2.12-1.7.el6.i686.rpm: glibc-2.12-1.7.el6.i686
          Marking glibc-2.12-1.7.el6.i686.rpm to be installed
          Resolving Dependencies
          --> Running transaction check
          ---> Package glibc.i686 0:2.12-1.7.el6 set to be updated
          --> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.7.el6.i686
          --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.7.el6.i686
          --> Finished Dependency Resolution
          Error: Package: glibc-2.12-1.7.el6.i686 (/glibc-2.12-1.7.el6.i686)
          Requires: libfreebl3.so(NSSRAWHASH_3.12.3)
          Error: Package: glibc-2.12-1.7.el6.i686 (/glibc-2.12-1.7.el6.i686)
          Requires: libfreebl3.so
          Try "yum install glibc*" command instead and see if you get the list of dependencies to be installed along with this RPM.
          You could try using --skip-broken to work around the problem
          You could try running: rpm -Va nofiles nodigest
          Did you try this?

          Thanks,
          Hussein
          • 2. Re: Issues in installing RPMs for RHEL 6
            MAveri((k
            Dear Hussain

            This is what i get

            [root@ebs RPMs]# yum install glibc*
            Loaded plugins: refresh-packagekit, rhnplugin
            This system is not registered with RHN.
            RHN support will be disabled.
            Setting up Install Process
            Examining glibc-2.12-1.7.el6.i686.rpm: glibc-2.12-1.7.el6.i686
            Marking glibc-2.12-1.7.el6.i686.rpm to be installed
            Examining glibc-2.12-1.7.el6.x86_64.rpm: glibc-2.12-1.7.el6.x86_64
            glibc-2.12-1.7.el6.x86_64.rpm: does not update installed package.
            Examining glibc-common-2.12-1.7.el6.x86_64.rpm: glibc-common-2.12-1.7.el6.x86_64
            glibc-common-2.12-1.7.el6.x86_64.rpm: does not update installed package.
            Examining glibc-devel-2.12-1.7.el6.i686.rpm: glibc-devel-2.12-1.7.el6.i686
            Marking glibc-devel-2.12-1.7.el6.i686.rpm to be installed
            Examining glibc-devel-2.12-1.7.el6.x86_64.rpm: glibc-devel-2.12-1.7.el6.x86_64
            Marking glibc-devel-2.12-1.7.el6.x86_64.rpm to be installed
            Resolving Dependencies
            --> Running transaction check
            ---> Package glibc.i686 0:2.12-1.7.el6 set to be updated
            --> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.7.el6.i686
            --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.7.el6.i686
            ---> Package glibc-devel.i686 0:2.12-1.7.el6 set to be updated
            --> Processing Dependency: glibc-headers = 2.12-1.7.el6 for package: glibc-devel-2.12-1.7.el6.i686
            --> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.7.el6.i686
            ---> Package glibc-devel.x86_64 0:2.12-1.7.el6 set to be updated
            --> Processing Dependency: glibc-headers = 2.12-1.7.el6 for package: glibc-devel-2.12-1.7.el6.x86_64
            --> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.7.el6.x86_64
            --> Finished Dependency Resolution
            Error: Package: glibc-devel-2.12-1.7.el6.i686 (/glibc-devel-2.12-1.7.el6.i686)
            Requires: glibc-headers
            Error: Package: glibc-2.12-1.7.el6.i686 (/glibc-2.12-1.7.el6.i686)
            Requires: libfreebl3.so
            Error: Package: glibc-devel-2.12-1.7.el6.x86_64 (/glibc-devel-2.12-1.7.el6.x86_64)
            Requires: glibc-headers = 2.12-1.7.el6
            Error: Package: glibc-2.12-1.7.el6.i686 (/glibc-2.12-1.7.el6.i686)
            Requires: libfreebl3.so(NSSRAWHASH_3.12.3)
            Error: Package: glibc-devel-2.12-1.7.el6.x86_64 (/glibc-devel-2.12-1.7.el6.x86_64)
            Requires: glibc-headers
            Error: Package: glibc-devel-2.12-1.7.el6.i686 (/glibc-devel-2.12-1.7.el6.i686)
            Requires: glibc-headers = 2.12-1.7.el6
            You could try using --skip-broken to work around the problem
            You could try running: rpm -Va nofiles nodigest

            Would also like to know if i have to set any yum repository for this. As f now i havent set up any and am not sure how to do that either.
            • 3. Re: Issues in installing RPMs for RHEL 6
              Hussein Sawwan-Oracle
              You could try using --skip-broken to work around the problem
              You could try running: rpm -Va nofiles nodigest
              What about these options?
              Would also like to know if i have to set any yum repository for this. As f now i havent set up any and am not sure how to do that either.
              You do not need a local copy if you are already connected to the internet and your machine is registered with RHEL/OEL network.

              Please google "yum repository" and you should get the answer.

              Thanks,
              Hussein
              • 4. Re: Issues in installing RPMs for RHEL 6
                MAveri((k
                Der Hussein

                I m not very sure as to how to use
                You could try using --skip-broken to work around the problem
                You could try running: rpm -Va nofiles nodigest

                Can u please provide some help on this.
                • 5. Re: Issues in installing RPMs for RHEL 6
                  Hussein Sawwan-Oracle
                  MAveri((k wrote:
                  Der Hussein

                  I m not very sure as to how to use
                  You could try using --skip-broken to work around the problem
                  You could try running: rpm -Va nofiles nodigest

                  Can u please provide some help on this.
                  http://www.cyberciti.biz/faq/centos-rhel-fedora-yum-missing-dependency/

                  Thanks,
                  Hussein
                  • 6. Re: Issues in installing RPMs for RHEL 6
                    alvaromiranda
                    Use package.x86_64 or package.i686

                    Yum clean all
                    Yum install glibc.i686

                    Paste the output
                    • 7. Re: Issues in installing RPMs for RHEL 6
                      MAveri((k
                      Dear Hussein

                      I tried --skip-broken. Here is the output for the same

                      [root@ebs RPMs]# yum install glibc-2.12-1.7.el6.i686.rpm --skip-broken
                      Loaded plugins: refresh-packagekit, rhnplugin
                      This system is not registered with RHN.
                      RHN support will be disabled.
                      Setting up Install Process
                      Examining glibc-2.12-1.7.el6.i686.rpm: glibc-2.12-1.7.el6.i686
                      Marking glibc-2.12-1.7.el6.i686.rpm to be installed
                      Resolving Dependencies
                      --> Running transaction check
                      ---> Package glibc.i686 0:2.12-1.7.el6 set to be updated
                      --> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.7.el6.i686
                      --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.7.el6.i686
                      --> Finished Dependency Resolution

                      Packages skipped because of dependency problems:
                      glibc-2.12-1.7.el6.i686 from /glibc-2.12-1.7.el6.i686


                      I dont thing the package is getting installed. Also wont skipping the reuired files cause any issues in installing R12?
                      • 8. Re: Issues in installing RPMs for RHEL 6
                        MAveri((k
                        HI

                        Is there a package called glibc.i686. I dint get this on the net and simply using the cammand returned

                        [root@ebs RPMs]# yum install glibc.i686
                        Loaded plugins: refresh-packagekit, rhnplugin
                        This system is not registered with RHN.
                        RHN support will be disabled.
                        Setting up Install Process
                        No package glibc.i686 available.
                        Error: Nothing to do
                        • 9. Re: Issues in installing RPMs for RHEL 6
                          Hussein Sawwan-Oracle
                          Please issue this command --> yum install glibc-*

                          Thanks,
                          Hussein
                          • 10. Re: Issues in installing RPMs for RHEL 6
                            MAveri((k
                            Dear Hussein

                            Is yum checking for RPM packages in current directory. I have created a directory where only those RPMs required for R12 are placed and issuing commands from there.

                            Should i try your command from installation cd/packages?
                            • 11. Re: Issues in installing RPMs for RHEL 6
                              Hussein Sawwan-Oracle
                              MAveri((k wrote:
                              Dear Hussein

                              Is yum checking for RPM packages in current directory. I have created a directory where only those RPMs required for R12 are placed and issuing commands from there.

                              Should i try your command from installation cd/packages?
                              Just change the directory to the one which is used to create your local repository and run the command from there -- http://www.oracle-base.com/articles/linux/installing-software-packages.php#yum_repositories

                              Thanks,
                              Hussein
                              • 12. Re: Issues in installing RPMs for RHEL 6
                                alvaromiranda
                                I think the glibc.i686 is already installed.

                                do:

                                yum list installed glibc

                                here's my output:

                                [oracle@mirandaa00 ~]$ yum list installed glibc glibc-devel
                                Loaded plugins: fs-snapshot, security
                                Installed Packages
                                glibc.i686 2.12-1.80.el6_3.6 @ol6
                                glibc.x86_64 2.12-1.80.el6_3.6 @ol6
                                glibc-devel.i686 2.12-1.80.el6_3.6 @ol6
                                glibc-devel.x86_64 2.12-1.80.el6_3.6 @ol6
                                [oracle@mirandaa00 ~]$

                                if not, then install as:

                                yum install glibc-devel.{i386,i586,i686,x86_64} glibc.{i386,i586,i686,x86_64}

                                upgrade as:

                                yum update glibc-devel.{i386,i586,i686,x86_64} glibc.{i386,i586,i686,x86_64}
                                • 13. Re: Issues in installing RPMs for RHEL 6
                                  MAveri((k
                                  Dear Alvaro

                                  Here is my output
                                  [root@ebs Desktop]# yum list installed glibc glibc-devel
                                  Loaded plugins: refresh-packagekit, rhnplugin
                                  This system is not registered with RHN.
                                  RHN support will be disabled.
                                  Installed Packages
                                  glibc.x86_64 2.12-1.7.el6 @anaconda-RedHatEnterpriseLinux-201009221801.x86_64/6.0
                                  glibc-devel.x86_64 2.12-1.7.el6 @/glibc-devel-2.12-1.7.el6.x86_64

                                  the problem is that i am not able to install the glibc-2.12-1.7.el6.i686.rpm and many other files with i686 version which are required for R12 due to dependency issues

                                  here is the output of my install command

                                  [root@ebs RPMs]# yum install glibc-2.12-1.7.el6.i686.rpm
                                  Loaded plugins: refresh-packagekit, rhnplugin
                                  This system is not registered with RHN.
                                  RHN support will be disabled.
                                  Setting up Install Process
                                  Examining glibc-2.12-1.7.el6.i686.rpm: glibc-2.12-1.7.el6.i686
                                  Marking glibc-2.12-1.7.el6.i686.rpm to be installed
                                  Resolving Dependencies
                                  --> Running transaction check
                                  ---> Package glibc.i686 0:2.12-1.7.el6 set to be updated
                                  --> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.7.el6.i686
                                  --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.7.el6.i686
                                  --> Finished Dependency Resolution
                                  Error: Package: glibc-2.12-1.7.el6.i686 (/glibc-2.12-1.7.el6.i686)
                                  Requires: libfreebl3.so(NSSRAWHASH_3.12.3)
                                  Error: Package: glibc-2.12-1.7.el6.i686 (/glibc-2.12-1.7.el6.i686)
                                  Requires: libfreebl3.so
                                  You could try using --skip-broken to work around the problem
                                  You could try running: rpm -Va nofiles nodigest


                                  Please suggest if i can take care of this by some means
                                  • 14. Re: Issues in installing RPMs for RHEL 6
                                    Hussein Sawwan-Oracle
                                    What about "yum install glibc-*"? Did you try this command?

                                    Thanks,
                                    Hussein
                                    1 2 Previous Next