4 Replies Latest reply: Jan 15, 2013 4:04 PM by Udo RSS

    Listener 2.0 and Java install

    patfmnd
      Hi,
      I am following the instructions for installing the Apex Listener 2.0 as a standalone listener on the same server as Apex. It is windows server. When I follow instructions to run 'java -jar apex.war' I am getting error -- java not recognized as internal or external command.

      Was there another step I am missing? I can't find any reference to any other configuration I am supposed to do to make Java available.

      Pat
        • 1. Re: Listener 2.0 and Java install
          Udo
          Hi Pat,

          you need to add the path to the directory that contains your Java binaries to your "search path" (usually an environment variable called PATH ).
          Depending on your OS this might be C:\Program Files\Java\jdk<version_number>\bin or something like +/usr/lib/jvm/java-6-sun+ (though it usually has a symbolic link in +/usr/bin+ on most linux/unix systems and +/usr/bin+ would usually be in your search path already...).
          Please note that any configuration or installation issues concerning your JDK should be searched in the documentation of your JDK (as there are different vendors with different kinds of installers for different operating systems...).

          -Udo
          • 2. Re: Listener 2.0 and Java install
            patfmnd
            Thanks,
            Appreciate your pointer. I went ahead and downloaded latest JDK and installed. Seems to work now.

            Pat
            • 3. Re: Listener 2.0 and Java install
              patfmnd
              Hi, Udo,
              I was able to run the java install, however I noticed an error in the command line window shown below and I cannot get to Apex through the URL with the Port I used--

              "Default Database connection not configured properly"

              I checked the default.xml file in the configuration directory and it has the correct database server name and correct port -- should I have used 'localhost' since it is on the same server. SID was also entered correctly although I don't notice the SID in default.xml file. Also, if I change the default.xml to 'localhost' how do I restart the listener? Instructions tell you to use 'CTRL-C' to stop, but what restarts?

              Any help would be appreciated!

              Pat

              Messages from the install--

              Jan 11, 2013 4:06:44 PM oracle.dbtools.standalone.Standalone execute
              INFO: Starting standalone Web Container in: c:\TEMP\listen_config\apex
              Jan 11, 2013 4:06:44 PM oracle.dbtools.standalone.Deployer deploy
              INFO: Will deploy application path = c:\TEMP\listen_config\apex\apex\WEB-INF\we
              .xml
              Jan 11, 2013 4:06:45 PM oracle.dbtools.standalone.Deployer deploy
              INFO: Deployed application path = c:\TEMP\listen_config\apex\apex\WEB-INF\web.x
              l
              Jan 11, 2013 4:06:45 PM oracle.dbtools.common.config.file.ConfigurationFolder l
              gConfigFolder
              INFO: Using configuration folder: C:\TEMP\listen_config\apex
              Default Database connection not configured properly
              Jan 11, 2013 4:06:46 PM oracle.dbtools.rt.web.SCListener contextInitialized
              INFO: Oracle Application Express Listener initialized
              Application Express Listener version : 2.0.0.354.17.06
              Application Express Listener server info: Grizzly/1.9.49

              Jan 11, 2013 4:06:46 PM com.sun.grizzly.Controller logVersion
              INFO: GRIZZLY0001: Starting Grizzly Framework 1.9.49 - 1/11/13 4:06 PM
              Jan 11, 2013 4:06:46 PM oracle.dbtools.standalone.Standalone execute
              INFO: http://localhost:8082/apex started.
              • 4. Re: Listener 2.0 and Java install
                Udo
                Hi Pat,
                SID was also entered correctly although I don't notice the SID in default.xml file
                That's odd. If none is entered, the default (XE) should be used. Anyway, using localhost on the localhost is a good idea, especially when the value you've entered instead possibly can't be resolved...
                Also, if I change the default.xml to 'localhost' how do I restart the listener?
                Just the way you started it...
                The error message is pretty clear. I'd recommend to rerun the configuration process. The safest way would be to delete your existing default.xml.

                -Udo