This discussion is archived
2 Replies Latest reply: Jan 16, 2013 5:26 AM by peter_raganitsch RSS

Erros in ApexLib after Apex 4.2 upgrade

665716 Explorer
Currently Being Moderated
We have upgraded our environment to Apex 4.2.1

We have an older application that makes use of ApexLib. We cannot remove ApexLib from the application without a lot of work.

ApexLib is now trhoughing an error:

in package apexlib_error procedure addApexValidationErrors WWV_Flow.g_validation_ids_in_error does not exist.

Has anyone had experience with how to resolve this issue?

Regards,
Bruce
  • 1. Re: Erros in ApexLib after Apex 4.2 upgrade
    665716 Explorer
    Currently Being Moderated
    I found the answer.

    Seems that ApexLib required an upgrade to release 2.2 in order to work with Apex 4.1 or higher. Release 2.2 resolved the errors.
  • 2. Re: Erros in ApexLib after Apex 4.2 upgrade
    peter_raganitsch Oracle ACE Director
    Currently Being Moderated
    Hi Clark,

    you are partially right. For ApexLib Framework to run under APEX 4.1 an upgrade is required to ApexLib Framework Version V2.2.

    But: After APEX 4.1 (i.e. 4.2, 5.0, ...) there is no support for ApexLib anymore. Please read this for some more information: http://www.oracle-and-apex.com/apexlib-framework-on-oracle-apex-4-2/

    brgds,
    Peter

    -----

    get Syntax Highlighting for the Application Builder: http://apex.oracle.com/pls/apex/f?p=APEX_DEVELOPER_ADDON:ABOUT:0:::::

    Blog: http://www.oracle-and-apex.com
    ApexLib: http://apexlib.oracleapex.info
    BuilderPlugin: http://builderplugin.oracleapex.info
    Work: http://www.click-click.at and http://www.wirsindapex.at
    Fantastic Plugins for APEX: http://www.tryfoexnow.com

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points