This discussion is archived
3 Replies Latest reply: Jan 18, 2013 6:33 AM by dominiquefortin RSS

Debug mode not working

dominiquefortin Newbie
Currently Being Moderated
Hi,

We are in the process of migrating from APEX v3.2.1 on 10g database to APEX v4.2.1 on 11g database. APEX is installed fresh on 11g. I was testing an application exported from v3.2.1 and imported in v4.2.1. I wasn't able to activate the debug mode from the developer bar when the application is running. The url changes but no debug information appears as was the case in v3.2.1. I can see a partial set of the debug information when I open then Show debug window from the developer bar. This show debug is incomplete. By that I mean I don't see session state change and I don't see information from "wwv_flow.debug" function.

I read in a thread for an earlier version 4, to toggle the debug field in edit application properties and apply, but that didn't work either. Something to note is that when the debug field in edit application properties was set to NO, I didn't get the error "Debugging is not enabled for this application" when activating the debug mode.

I created an application form scratch and the debug mode doesn't work either.

Is there some global setting in administration somewhere that I should enable to get the debug information in the page like in v3.2.1?
  • 1. Re: Debug mode not working
    fac586 Guru
    Currently Being Moderated
    dominiquefortin wrote:

    We are in the process of migrating from APEX v3.2.1 on 10g database to APEX v4.2.1 on 11g database. APEX is installed fresh on 11g. I was testing an application exported from v3.2.1 and imported in v4.2.1. I wasn't able to activate the debug mode from the developer bar when the application is running. The url changes but no debug information appears as was the case in v3.2.1.
    No debug information is displayed in-line in the page in APEX 4.x. It all appears in the debug window.
    I can see a partial set of the debug information when I open then Show debug window from the developer bar. This show debug is incomplete. By that I mean I don't see session state change and I don't see information from "wwv_flow.debug" function.
    Note that the Debug window contains an interactive report that applies a default filter for the last page viewed. You might not be seeing the report for the page you want. Remove the page filter to see all of the currently available debug reports. There are also separate reports for each page show/accept, so make sure you're selecting the correct phase.
    I read in a thread for an earlier version 4, to toggle the debug field in edit application properties and apply, but that didn't work either. Something to note is that when the debug field in edit application properties was set to NO, I didn't get the error "Debugging is not enabled for this application" when activating the debug mode.
    I think I may have seen a bug for this, but I can't find a reference at present.
    Is there some global setting in administration somewhere that I should enable to get the debug information in the page like in v3.2.1?
    No. All debug information is now displayed in the debug window.
  • 2. Re: Debug mode not working
    Patrick Wolf Employee ACE
    Currently Being Moderated
    Hi Dominique,

    as Paul already pointed out, all the debug information is now displayed when you click "View Debug" in the developer toolbar. Be aware that you have to enable debugging by click "Debug" before you will see anything in the "View Debug" window.
    I can see a partial set of the debug information when I open then Show debug window from the developer bar. This show debug is incomplete. By that I mean I don't see session state change and I don't see information from "wwv_flow.debug" function.
    Please make sure that you view the debug output for the "accept" view identifier. You will find that information in the "Path Info" column of the report you get when you click "View Debug".
    About your missing wwv_flow.debug entries, they should definitely be included if you run your page in debug mode.

    As Paul mentioned, you might have to remove the filter of the IR to see all the view identifiers.
    I didn't get the error "Debugging is not enabled for this application" when activating the debug mode.
    It's not necessary anymore to enable debugging as long as you run the application from the APEX Builder.
    I created an application form scratch and the debug mode doesn't work either.
    Can you reproduce that on apex.oracle.com?

    BTW, in APEX 4.2 you can now use LEVEL1 - LEVEL9 instead of the YES/NO debug flag in the URL to get more detailed information. In addition there are new APEX_DEBUG APIs which you should use instead of wwv_flow.debug. See http://docs.oracle.com/cd/E37097_01/doc/doc.42/e35127/apex_debug.htm#BCGIGEFJ for details

    Regards
    Patrick
  • 3. Re: Debug mode not working
    dominiquefortin Newbie
    Currently Being Moderated
    Thanks. That helped.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points