1 Reply Latest reply: Jan 17, 2013 5:30 AM by Mayumi-Oracle RSS

    Deploy the larger rulebases and determinations-server to WSL 10.3.5 slow

    Mayumi-Oracle
      On : 10.1.0.27 version, Oracle Policy Automation
      Determination Server
      WLS managed server

      ACTUAL BEHAVIOR
      ---------------
      Deploy the larger rulebases and determinations-server to WSL 10.3.5
      It takes around 20 minutes to deploy.
      Often the WLS times out during the deployment and we find the only way of getting the determinations-server to run again is to restart the WLS managed server.

      EXPECTED BEHAVIOR
      -----------------------
      No time or delay to deploy.

      Business impact
      -----------------------
      On the way deploy rule base WLS server sometimes timeout.
        • 1. Re: Deploy the larger rulebases and determinations-server to WSL 10.3.5 slow
          Mayumi-Oracle
          The customer improved as follows solution.

          The customer have changed the way deploy the rulebases and this has reduced the deployment time dramatically.
          They have 3 rulebases and one of Billing is the largest by far.
          They have split the billing into an out of the box determinations-server and are deploying it as a war.
          The whole process is now acceptable.

          === ODM Data Collection ===
          <Info> <WebService> <c17ssit1.lab.gov> <opasit1_server1> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <bfeae85a12c63a65:-b8294b1:13ad04153dd:-8000-0000000000000003> <1352114445944> <BEA-220103> <Async web service support is not fully configured. The async response web service /AsyncResponseServiceHttps for this server was not fully deployed because the JMS reliability queue was not defined/deployed: weblogic.wsee.DefaultQueue. The server will periodically retry completing the deploy for the service. This message can usually be ignored unless there are async web service applications. To completely disable async web service support, thus avoiding this message, set -Dweblogic.wsee.skip.async.response=true.>

          <Warning> <Socket> <c17ssit1.lab.gov> <opasit1_server1> <ExecuteThread: '0' for queue: 'weblogic.socket.Muxer'> <<WLS Kernel>> <> <> <1352204469466> <BEA-000450> <Socket 328 internal data record unavailable (probable closure due idle timeout), event received 0>
          <Warning> <Socket> <c17ssit1.lab.gov> <opasit1_server1> <ExecuteThread: '2' for queue: 'weblogic.socket.Muxer'> <<WLS Kernel>> <> <> <1352204534404> <BEA-000450> <Socket 342 internal data record unavailable (probable closure due idle timeout), event received -32>