1 Reply Latest reply: Jan 20, 2013 8:29 PM by Srinath Menon-Oracle RSS

    Indexer is slow for large size content

    Prashant ECM
      Hi,

      I was uploading some large size content around 10 MB to 50 MB in content server and the indexer is set to Metadata indexing only no full text search enabled.

      These contents are JPG or Tiff files.

      Content got stuck in done state, I tried all possible ways ... deleting index related folders (given in one of the post) collection rebuild, Running IDC analyzer and doing cleanup but didn't got sucess.

      Finally i took all the content in a Archive and clear out the indexing queue and tried doing a normal checkin for 10 - 15 content with small size (approx 10 KB to 1MB ) got released and indexed easily.

      then I tried importing content one by one form Archive ( Created for large content ). Each file 0f 10 MB took approx 45 - 50 minutes and Content more than 20 MB got stuck in Queue for more than 5 hrs.

      Surprisingly when I was importing content form Archive shows in Repository manager in Done state but still searchable.

      Content Server Status:
      Auto indexing enabled & set to 10 & 10000

      Rebuild cycle finished and set to 25 & 10000

      Total load on content server is 40 - 50 content per day.

      Total size for Vault and Weblayout : Total : 4TB Ava :2.5 TB

      Please let me know is there any configuration i am missing and why UCM server is taking so much time to index large files if Full text search is not enabled ?

      Thanks,
      Prashant
        • 1. Re: Indexer is slow for large size content
          Srinath Menon-Oracle
          Hi ,

          This looks to be a classic case of performance issue when indexer is running . Infact a DB level performance issue looks to be the problem here . First you will need to see which DB operation is taking the maximum time so that specific ones can be fine-tuned .For that set the following tracing options :

          systemdatabase*,requestaudit,indexer*

          Check Full Verbose tracing option and update the settings .

          Navigate to view server output and clear the existing logs .

          Check-in a new content and wait for the time you think it takes to complete indexing .

          Then go to Server output and check the logs to see what db operations are taking maximum time .

          Before this you should check with your DBA to see how good is DB health and also drop the indexes for the following tables and rebuild them :

          Documents
          Revisions
          Indexerstate
          Counters
          Colmeta(if folders are enabled)
          Docmeta

          Hope this helps .

          Thanks,
          Srinath