1 Reply Latest reply on Jan 21, 2013 3:23 PM by jariola

    Radiogroup Issue

      Hello i have an issue using radiogroups in APEX

      Our Setup: APEX 4.0 using EPG

      I'm using an interactive report that present distint records to my client.
      On each record they need the option "Yes" or "No" which will flag that record accordingtly.

      I'm using radiobuttons because it can only be "yes" or "no" option selected.

      In my query i tried using APEX_ITEM.RADIOGROUP(rownum,.........) to generate distinct id's for my records.
      It works but after 99 radiobuttons it resets.
      Example F99 then resets to F00, F02, F03 and so on.
      It should be F100, F102 and so on, but thats the limit of APEX.RADIOGROUP i believe.

      So i decided to create the radiobuttons using HTML and rownum.
      It works perfectly fine.

      Like so:
      *'<fieldset class="radio_group">'||*
      *'<input type="radio" name="'||rownum||'" value="'||d_id" onclick="spCheckChange(this);">Yes'||*
      *'<input type="radio" name="'||rownum||'" value="'||d_id" onclick="spCheckChange(this);">No'||*
      *'</fieldset>' radiobox, mat_view.**

      from table_id

      I'm using an on demand process that keeps track of which radiogroup buttons are checked. This works fine.

      However, i have a submit button on the page that does an insert into a table with the items selected.
      I get an error "The HTTP client sent a request that this server could not understand." in Firefox

      It seems to be a bug.
      I tried this and it doesnt work either when hitting submit:

      *'<input type="radio" name="1" value="hello">Yes'*

      from dual

      I tried it on APEX 4.1 and it does the same thing.

      Try it yourself.
      Create a interactive report. With the above query.
      Create a submit button. You don't need to input a process to insert anything.
      When you run the page, select the radio group . Then hit "submit"
      You will get the error.

      If you run the page without hitting the radiogroup, and it submit, you don't get the error.
      It seems like APEX doesnt like '<input type="radio" name="1" value="hello">Yes' in the query

      Any ideas?

      Edited by: INAMIK on Jan 21, 2013 9:43 AM

      Edited by: INAMIK on Jan 21, 2013 10:15 AM
        • 1. Re: Radiogroup Issue

          Input tag name attribute is parameter name for procedure when you submit page.
          There is no parameter name like 1. This is not bug

          And as I remember you can have only 50 arrays, meaning f01 - f50.
          That is limit of tabular form columns.

          My Blog: http://dbswh.webhop.net/htmldb/f?p=BLOG:HOME:0
          Twitter: http://www.twitter.com/jariolai