1 Reply Latest reply on Jan 22, 2013 9:25 PM by Patrick Taylor

    Proxy Service giving "Cannot Compute Effective WSDL for: Proxy Service"


      After updating the wsdl and schema, our proxy service is complaining with error : "Cannot Compute Effective WSDL for: Proxy Service " <ProxyService_Location_Name> when I launch a test console or access the Proxy Endpoint on IE.

      Proxy and Business Services are pointing to the same WSDL. From Business Service, I am able to launch the test console. . Before updating the wsdl and schema, it was working fine. We tried to check in JDeveloper to see whether there are any issues with WSDL or Schema, but they are working fine.

      Security Settings on Proxy Service are : Basic Authentication, User-Name Token Policy and also applied Transport Access Control. Security worked fine earlier before update.

      From log file :
      Root cause of ServletException.
      java.io.IOException: Can not compute effective WSDL for : ProxyService ********
      at com.bea.wli.sb.transports.http.ResourceRequestProcessor.securedInvoke(ResourceRequestProcessor.java:93)
      at com.bea.wli.sb.transports.http.ResourceRequestProcessor.process(ResourceRequestProcessor.java:65)
      at com.bea.wli.sb.transports.http.generic.RequestHelperBase.handleMetadataRequest(RequestHelperBase.java:181)
      at com.bea.wli.sb.transports.http.generic.RequestHelperBase.service(RequestHelperBase.java:83)
      at com.bea.wli.sb.transports.http.wls.HttpTransportServlet.service(HttpTransportServlet.java:127)
      at weblogic.servlet.FutureResponseServlet.service(FutureResponseServlet.java:24)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)

      Any suggestions/ideas on why this error is happening is much appreciated.

        • 1. Re: Proxy Service giving "Cannot Compute Effective WSDL for: Proxy Service"
          Patrick Taylor
          There must be definitely some issue in the Policy Configuration, due to which it is not able to Compute Effective WSDL.

          Can you please do the following and capture the logs:

          - set the transports debug flag to true in the alsbdebug.xml in your domain directory :


          - set the WLS log level to debug
          - Then restart the servers

          This should give some additional details on the specific error.

          It is considered good etiquette to reward answerers with points (as "helpful" - 5 pts - or "correct" - 10pts).
          1 person found this helpful