This discussion is archived
2 Replies Latest reply: Jan 27, 2013 3:26 AM by Working! RSS

Authentication failure when adding new 'Segment in Use'

mroshaw76 Explorer
Currently Being Moderated
Hi all!

I've set up integration between Siebel 8.1.1.9 and OBIEE 11.1.1.5.0. I've applied My Oracle Support article ID 1400715.1, importing the modified SIF and Workflow definitions and re-deployed the SRF to the server.

When attempting to drill into a folder in the 'Pick Segment' applet, I get the following error:

Operation 'impersonate' of Web Service 'com.siebel.analytics.web/soap/v1.SAWSessionService' at port 'SAWSessionServiceSoap' failed with the following explanation:
"Authentication error. An invalid User Name or Password was entered.".(SBL-EAI-04308)

I cannot for the life of me work out why this is happening. I've followed 1400715.1:

1. Created a new OBIEE user called 'impersonateuser' and added the 'oracle.bi.server.impersonateUser' permission
2. In Siebel, Marketing - Administration > Servers, I've set the User Id and Password fields for the 'Default Analytics Web Server' entry, ensuring that the password contains more than 8 characters and contains a number, with the 'impersonateuser' details. The 'impersonateuser' user can successfully log in to OBIEE / Dashboard

I've checked the Web Service definitions and replaced host name with host:port. The Web Service is definitely getting invoked but there seems to be a problem with the impersonation.

Any thoughts on how to resolve this?

Many thanks!

mroshaw

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points