4 Replies Latest reply: Jul 15, 2013 9:46 AM by jstem1177 RSS

    WLST - nmServerStatus UNKNOWN - Weblogic Admin Console RUNNING

      Hello All,

      I'm looking into the WLST to do some simple monitoring with perl. However I noticed that when ever I use the node manager option for status WLS_REPORTS I always get UNKNOWN.

      I've got a basic forms and reports setup on windows with the managed servers 'defaults' WLS_FORMS, WLS_REPORTS etc on weblogic 10.3.4

      Maybe somebody can point out what I'm doing wrong as when I go through the weblogic administration web console I see all the servers RUNNING.

      D:\Oracle\Middleware\wlserver_10.3\server\bin>java weblogic.WLST
      Initializing WebLogic Scripting Tool (WLST) ...
      Welcome to WebLogic Server Administration Scripting Shell
      Type help() for help on available commands
      wls:/offline> connect('weblogic','*****','t3://PHXAP00:7001')
      Connecting to t3://PHXAP00:7001 with userid weblogic ...
      Successfully connected to Admin Server 'AdminServer' that belongs to domain 'Domain_QA'.
      Warning: An insecure protocol was used to connect to the
      server. To ensure on-the-wire security, the SSL port or
      Admin port should be used instead.
      wls:/Domain_QA/serverConfig> cd('Servers')
      wls:/Domain_QA/serverConfig/Servers> ls()
      dr--   AdminServer
      dr--   WLS_DISCO
      dr--   WLS_FORMS
      dr--   WLS_REPORTS
      wls:/Domain_QA/serverConfig/Servers> disconnect()
      Disconnected from weblogic server: AdminServer
      Now here is how I'm check the status of the servers WLS_FORMS & WLS_REPORTS:
      wls:/offline> nmConnect('weblogic','****','PHXAP00','5556','Domain_QA','D:\Oracle\Middleware\user_projects\domains\Domain_QA','SSL')
      Successfully Connected to Node Manager.
      wls:/nm/Domain_QA> nmServerStatus('WLS_REPORTS')
      wls:/nm/Domain_QA> nmServerStatus('WLS_FORMS')
      wls:/nm/Domain_QA> nmServerStatus('WLS_DISCO')
      wls:/nm/Domain_QA> nmServerStatus('AdminServer')
      As I mentioned I can access the Weblogic Administration console and I see all the servers are RUNNING.

      Thanks in advance for any pointers.

      Jan S.
        • 1. Re: WLST - nmServerStatus UNKNOWN - Weblogic Admin Console RUNNING
          Kishore Rout
          This will show the status as UNKNOWN. You can do one thing shutdown Adminserver and managed servers. You can use below command to start admin and managed server, then check the status using "nmServerStatus" commnd.

          Connect node manager using nmConnect command. Issue below commands

          After successful start, check the status using nmServerStatus.

          if this helps, Please mark.

          • 2. Re: WLST - nmServerStatus UNKNOWN - Weblogic Admin Console RUNNING

            I tried to to kill the serves but that also failed from Node Manager so I stopped the servers from the AdminServer using shutdown.

            I noticed that if I first connect to the admin server and then to the node manager I get the proper information. Probably that is the step I skipped (WLST --> connect to AdminServer --> connect to NodeMnager --> nmServerStatus('WLS_REPORTS').

            However, I found that I could also use state to get the same sort of information and don't need to connect to the nodeManager.
            wls:> shutdown('WLS_REPORTS','Server','true',1200)
            wls:> start('WLS_REPORTS','Server','true',1200)
            wls:>  state('WLS_REPORTS','Server')
            Current state of 'WLS_REPORTS' : RUNNING

            Jan S.
            • 3. Re: WLST - nmServerStatus UNKNOWN - Weblogic Admin Console RUNNING

              Hi Jan S.


              I didn't understand that, Why do we need to give the last parameter value as 1200? I have tried to see the syntax for the start() command it doesn't shows any number argument required!


              Please reply on this.

              Thanks in advance!



              • 4. Re: WLST - nmServerStatus UNKNOWN - Weblogic Admin Console RUNNING

                Hello Pavan,

                Sorry I no longer have access to the weblogic servers. I've checked my notes and do not see why I used 1200. I know there are several arguments for start() & shutdown() and its possible that I'm made a TYPO where 1200 should be the listening port (9002) in my case.




                Jan S.