1 Reply Latest reply on Jan 24, 2013 4:48 AM by damorgan

    XML table error

      Hi ll,

      I ran this query to search for a word 'UPR'

      select table_name, x.*
      from (select table_name,
      'ora:view("' || table_name || '")/ROW/'
      || '[contains(lower-case(xs:string(.)), "'
                     || lower (:search)
                     || '")]/text()' str
      from all_tables
      xmltable (str) x

      and came across thsi set of error from teh XML table
      ORA-19112: error raised during evaluation:
      XVM-01003: [XPST0003] Syntax error at '['
      1 ora:view("ICOL$")/ROW/[ora:contains(text(),"%AUSGRID%") > 0]
      - ^

      19112. 00000 - "error raised during evaluation: %s"
      *Cause:    The error function was called during evaluation of the XQuery expression.
      *Action:   Check the detailed error message for the possible causes.

      Oracle version is
        • 1. Re: XML table error
          You already have a thread open on this. Please mark this thread as solved and go back to the original.

          It is considered bad form here to repost and repost the same question.

          If the volunteers here do not give you an answer satisfactory to your needs then open a Service Request with Oracle.