This discussion is archived
2 Replies Latest reply: Jan 28, 2013 1:39 AM by 710129 RSS

Data Export - Export slows and slows until dead

710129 Newbie
Currently Being Moderated
I am trying to export 132K rows from a table to an .xlsx format.
The data is 6 columns wide, no large ones: 3 a max of 10 char, 2 dates and 1 single char field

Before i start SQL Dev memory usage is at about 256M when i kick off the export it peaks upto about 784M, once it hits 700M the export process slows right down the export count showing 2/3 records at a time being exported instead of the usual 100s/1000s then it white screens out and is non responsive.

Is this a SQL Dev issue i can fix in the conf file or is it a Laptop issue ?

I am running XP, with 3G of ram, CPU at around 50-70% with SQL Dev taking approx 50

Sorry should add i am using the latest version of SQL Dev 3.2.20.09

Edited by: Trotty on Jan 24, 2013 10:26 AM
  • 1. Re: Data Export - Export slows and slows until dead
    Jeff Smith SQLDev PM ACE Moderator
    Currently Being Moderated
    You're exhausting the JVM. Well, you're not, we are. The current method we use to create XLS files isn't optimal and we're looking to address it in a future release.

    In the meantime, you have two options:
    Use CSV instead of XLS - fast
    Increase the JVM so we can use more memory - works but takes more memory

    For the 2nd option find this line in your sqldeveloper.conf file in the sql developer bin directory
    AddVMOption -XX:MaxPermSize=256M

    Change the 256M to something larger. The amount required will largely depend on the amount of data you're writing to XLS.
  • 2. Re: Data Export - Export slows and slows until dead
    710129 Newbie
    Currently Being Moderated
    Thanks Jeff,

    Tried updating the memory, but didn't make any difference, in fact kept going up and when got to 1024 SQL Dev wouldn't even start.

    I did get the extract i mentioned to extract using export to CSV so thanks for that, however then the next extract which was 300K rows same no of colums then caused the same issue even using export -> csv.

    So used the /*csv*/ hint with a spool and that seems to work for now.

    Thanks
    Paul

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points