3 Replies Latest reply: May 31, 2013 2:47 PM by user730626 RSS

    Portlet timeout

    user730626
      Sr-3-6708037881
      Vver-11.1.1.4.0

      We are seeing portlet timeout that are inconsistant with the timeout specified in portlet producer registartion screen. We have 3000 as portlet timoout in the portlet producer screen but portlets are timing out in 30 seconds or less. We need some help here, here are other timeouts setup in our portal application

      web.xml
      session-timeout : 15 (min)
      oracle.adf.view.rich.sessionHandling.WARNING_BEFORE_TIMEOUT : 180 (sec)

      adf-config.xml
      adf-portlet-config:defaultTimeout : 20 (sec)
      adf-portlet-config:minimumTimeout : 1(sec)
      adf-portlet-config:maximumTimeout: 60 (sec)


      According to documentation at http://docs.oracle.com/cd/E23943_01/webcenter.1111/e10148/jpsdg_files.htm#CHDJBHBE timeouts in the adf-config.xml are just default values and should be used only when portlet producer does not provide them.

      Can you please help us find what we need to do to fix timeout issue.
        • 1. Re: Portlet timeout
          mcano-Oracle
          The Portlet registration timeout cannot exceed the maximumTimeout in adf-config.xml file as indicated here:

          http://docs.oracle.com/cd/E17904_01/webcenter.1111/e10148/jpsdg_files.htm#CHDJBHBE

          This is also mentioned in the following internal bug (closed as not a bug): Bug:7630923

          From the above bug:

          @ The issue is the timeout set during registration (say 600 secs) is not
          @ honored because the maximumTimeout in adf-config.xml is set to 60 secs.
          ...

          @ The point of the max timeout is that the you can cap the timeout to avoid the
          @ system grinding to a halt. This should be set at a system level.
          @ .
          @ If during registration that value could be increased by any user of the
          @ system that would then bypass that safeguard completely.
          @ .
          @ This is at very least an er, but I would say not a bug.


          So if they want to increase the producer timeout to a value greater than 60 seconds then they need to increase the maximumTimeout in adf-config.xml file.

          This however doesn't explain why they say the portlets are timing out before 30 seconds.

          There are other bugs for their release.
          One of them is this internal bug:

          Bug 12902538 - CANNOT UPDATE TIMEOUT AFTER REGISTRATION.

          This is form the above bug:

          It's not possible to update the portlets Default Timeout value after first
          registration in jdev or other tools.

          Updating the timeout in jdev, for example, will update the timeout stored on
          the connection. However, it turns out that it's the DefaultPortletTimeout
          stored on the <wsrpProducer/> meta that actually gets used at runtime and the
          value stored on here doesn't get updated. Essentially then, you are stuck
          with the value you used when you first registered the producer.
          ...

          This bug is fixed in 11.1.1.6.0.
          So check with the customer if they originally registered the producer with a lower timeout.
          If this is the case it could be this bug.
          • 2. Re: Portlet timeout
            mcano-Oracle
            The issue was fixed with the following settings:

            1. Ensure the HTTP Session Timeout in the producer and consumer is set to the same time.
            For example, assuming you want a timeout of 60 minutes:

            Web.xml (timeout in web.xml file is specified in minutes)

            <session-config>
            <session-timeout>60</session-timeout>
            </session-config>


            Weblogic.xml (timeout in weblogic.xml file is specified in seconds)

            <session-descriptor>
            <timeout-secs>3600</timeout-secs>
            </session-descriptor>

            The above settings must be done in the producer and consumer.



            2. Set the maximumTimeout in adf-config.xml file to a greater value
            (or same value) as the timeout you are seting when registering the producer.

            So for example, if your portlet registration timeout is 3000 seconds then
            you need to update the maximumTimeout in adf-config.xml file as follows:

            <maximumTimeout>3000</maximumTimeout>


            This setting is for the producer.

            Edited by: mcano on May 31, 2013 12:27 PM
            • 3. Re: Portlet timeout
              user730626
              Thnaks aMartha this is resolved after changing the web.xml and weblogic.xml with proper time out settings.