5 Replies Latest reply: Jan 27, 2013 2:38 AM by HakanBiroglu RSS

    SMTP Settings

    987132
      i want to use aol smtp settings for my DEMO system

      the setting i have given in PSAPPSRV.CFG is

      SMTPServer=smtp.aol.com
      SMTPPort=587
      SMTPSender=mymail@aol.com
      SMTPSourceMachine=AppServerName
      SMTPCharacterSet=UTF-8
      ;both the username and password are not encrypted given it for as it is
      SMTPUserName=mymail@aol.com
      SMTPUserPassword=XXXXXXXX
      SMTPUseSSL=y
      SMTPSSLPort=587
      SMTPClientCertAlias=


      when i try to send mail from SENDMAIL function

      smtptrace shows

      250-PIPELINING
      250-SIZE 36700160
      250-ETRN
      250-STARTTLS
      250-AUTH XAOL-UAS-MB PLAIN LOGIN
      250-AUTH=XAOL-UAS-MB PLAIN LOGIN
      250-ENHANCEDSTATUSCODES
      250-8BITMIME
      250 DSN
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "PIPELINING", arg ""
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "SIZE", arg "36700160"
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "ETRN", arg ""
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "STARTTLS", arg ""
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "AUTH", arg "XAOL-UAS-MB PLAIN LOGIN"
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "AUTH=XAOL-UAS-MB", arg "PLAIN LOGIN"
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "ENHANCEDSTATUSCODES", arg ""
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "8BITMIME", arg ""
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Found extension "DSN", arg ""
      Fri Jan 25 03:20:15 IST 2013 DEBUG SMTP: Attempt to authenticate
      Fri Jan 25 03:20:15 IST 2013 AUTH LOGIN
      Fri Jan 25 03:20:15 IST 2013 334 VXNlcm5hbWU6
      Fri Jan 25 03:20:15 IST 2013 a2lyYW5rdW1hci5nLjE5ODJAYW9sLmNvbQ==
      Fri Jan 25 03:20:16 IST 2013 334 UGFzc3dvcmQ6
      Fri Jan 25 03:20:16 IST 2013 a2lyYW5rdW1hci5nLjE5ODJAYW9sLmNvbQ==
      Fri Jan 25 03:20:16 IST 2013 535 5.7.8 Error: authentication failed: authentication failure
      Fri Jan 25 03:20:16 IST 2013 DEBUG SMTP: useEhlo true, useAuth true
      Fri Jan 25 03:35:56 IST 2013 DEBUG: getProvider() returning javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.smtp.SMTPTransport,Sun Microsystems, Inc]
      Fri Jan 25 03:35:56 IST 2013 DEBUG SMTP: useEhlo true, useAuth true




      can any body resolve my problem pleaseeee
        • 1. Re: SMTP Settings
          HakanBiroglu
          I think the password should be encrypted in the psappsrv.cfg, the rest of the setting look fine.

          See this doc
          E-MCF: How Can Username & Password be Passed to SMTP Server [ID 650909.1]

          Also see PeopleBooks saying the password needs to be encrypted
          PeopleBooks > PeopleTools 8.52: System and Server Administration > Setting Application Server Domain Parameters > SMTPUserPassword
          http://docs.oracle.com/cd/E28394_01/pt852pbh1/eng/psbooks/tsvt/book.htm?File=tsvt/htm/tsvt07.htm#H4137

          Hakan

          Edited by: Hakan Biroglu on Jan 25, 2013 3:19 PM
          • 2. Re: SMTP Settings
            987132
            Hi Hakan

            i encrypted password using PSCipher tool..

            and it given the code *{V1.1}Htc0cxxpu+RaOpvBIpb3r5IgudQEvjJy*

            i copied this and applied in psappsrv.cfg file..

            but result is same it showing same error Authorization failed in trace file
            • 3. Re: SMTP Settings
              HakanBiroglu
              I tried creating a AOL mail account and tried configuring my appserver to smtp.aol.com:587.
              I cannot even get a connection to smtp.aol.com
              I think my ISP is blocking this, which a lot of ISP do to avoid spam.

              I read in a couple of posts that the username should be the first part of your mail address.
              Try changing SMTPUserName to:
              SMTPUserName=hakan.biroglu

              where my oal mail account is hakan.biroglu@aol.com.

              Regards,

              Hakan
              • 4. Re: SMTP Settings
                987132
                Hi HAkan,

                Thanku for Responding

                i triend like u said but it showing same Authorization error

                even i tried with encrypting both username and password..but didnt resolve the issue :(
                • 5. Re: SMTP Settings
                  HakanBiroglu
                  Since this is a demo environment, i assume you do not really want to send mails, but see that mail is being send from PeopleSoft.

                  On my sandboxes I always install (freeware) [url http://www.postcastserver.com/]PostCastServer to catch the mails from PeopleSoft, instead of actually sending it.
                  Give it a try ..

                  After installing PostCastServer, you can configure your appserver with
                  host: machinename/localhost
                  port: 25
                  No authentication required.

                  When sending mail from PeopleSoft, you can see the mails coming in PostCastServer and PeopleSoft is in the assumption that mails have been successfully send.

                  Hope this helps.

                  Regards,

                  Hakan