4 Replies Latest reply: Jan 27, 2013 8:11 AM by jkostic RSS

    configure asm disk manualy by setting up udev on suse linux 11 SP2

    jkostic
      Hi Guys,

      I have setup several times asm disk by setting up udev on OEL but following documentation here doesn't work for me.

      Any help on the full procedure would be great.

      The customer doen't use multipath.

      Thanks
      jko
        • 1. Re: configure asm disk manualy by setting up udev on suse linux 11 SP2
          Dude!
          I cannot see why the configuration of the Udev subsystem under SLES 11 should be any different from Oracle Linux.

          Perhaps you can install Oracle ASMlib, which can make managing of ASM disks more user friendly. As far as I know, Novell provides the kernel driver (oracleasm-kmp-default), and you can download the remaining software from http://www.oracle.com/technetwork/server-storage/linux/downloads/sles11-099661.html.
          • 2. Re: configure asm disk manualy by setting up udev on suse linux 11 SP2
            jkostic
            Thanks dude!

            The goal here was to replace asmlib because to os version dependent.

            I found the solution:

            -create the /etc/scsi_id.config file as it doesn't exist in suse linux, at least for my case...
            add following in it

            vendor="ATA",options=-p 0x80
            options=-g

            get uids for required disks:

            /lib/udev/scsi_id /dev/sdd
            14f504e46494c450073726546676f2d465a47322d524b3357
            ...

            create the 99-oracle-asmdevices.rules rule file in /etc/udev/rules.d folder

            add udev rules as follow

            KERNEL=="sd?1",BUS=="scsi",ENV{ID_SERIAL}=="14f504e46494c45005a4579666b632d426c72632d59594e6c", NAME="asmcrs1", OWNER="grid", GROUP="asmadmin", MODE="0660"
            KERNEL=="sd?1",BUS=="scsi",ENV{ID_SERIAL}=="14f504e46494c450073726546676f2d465a47322d524b3357", NAME="asmcrs2", OWNER="grid", GROUP="asmadmin", MODE="0660"

            restart udev
            /etc/init.d/boot.udev stop
            /etc/init.d/boot.udev start

            ls /dev/asm*
            brw-rw---- 1 grid asmadmin 8, 128 Jan 27 13:34 /dev/asmcrs1
            brw-rw---- 1 grid asmadmin 8, 129 Jan 27 13:34 /dev/asmcrs2

            Done
            Then I was able to define a new diskgroup and move OCR files, votings and asm spfile in it, and get rid of asmlib.

            Thanks
            jko

            Edited by: 966548 on Jan 27, 2013 4:47 AM
            • 3. Re: configure asm disk manualy by setting up udev on suse linux 11 SP2
              Dude!
              I found the solution:
              The creation of /etc/scsi_id to configure trusted SCSI devices is actually mentioned in the documentation you outlined in your initial post.

              You might want to check your owner and group for the ASM devices. Normally they are user "oracle" and group "dba". It needs to be according to the information you entered when you installed the Grid software.
              • 4. Re: configure asm disk manualy by setting up udev on suse linux 11 SP2
                jkostic
                Hi Dude,

                This doesn't works
                KERNEL=="sd?1",BUS=="scsi", PROGRAM=="/lib/udev/scsi_id",RESULT=="14f504e46494c45005a4579666b632d426c72632d59594e6c", NAME="asmcrs1", OWNER="grid", GROUP="asmadmin", MODE="0660"
                KERNEL=="sd?1",BUS=="scsi", PROGRAM=="/lib/udev/scsi_id",RESULT=="14f504e46494c450073726546676f2d465a47322d524b3357", NAME="asmcrs2", OWNER="grid", GROUP="asmadmin", MODE="0660"

                This works
                KERNEL=="sd?1",BUS=="scsi",ENV{ID_SERIAL}=="14f504e46494c45005a4579666b632d426c72632d59594e6c", NAME="asmcrs1", OWNER="grid", GROUP="asmadmin", MODE="0660"
                KERNEL=="sd?1",BUS=="scsi",ENV{ID_SERIAL}=="14f504e46494c450073726546676f2d465a47322d524b3357", NAME="asmcrs2", OWNER="grid", GROUP="asmadmin", MODE="0660"

                Regarding ownership, it's in line with the grid infrastructure installation.

                Cheers,
                jko