6 Replies Latest reply: Jan 29, 2013 1:54 PM by JohnGoodwin RSS

    Foundation Services - Configure Web server fails

    hyperion start
      I am re-installing reconfiguring EPM and now each time I try to configure Foundation Services, the CONFIGURE WEB SERVER fails.
      Could there be any reason it is failing. Oracle HTTP is what I am using.
      I can log on to shared services with the 28080, but I cannot log in to Workspace.
      Also, planning has configured properly as there seems to be no error, but when I start EPM, Planning - Web application does not start.
      Please guide.
        • 1. Re: Foundation Services - Configure Web server fails
          You will need to check the config logs to see why OHS is failing to configure, it may be easier to backup and clear down the log first, then run the config and check the log, log details - http://docs.oracle.com/cd/E17236_01/epm.1112/epm_install_troubleshooting_11121/ch03s02s05.html

          When you say planning does not start are you meaning the windows service, if so have you tried starting it by a script.


          • 2. Re: Foundation Services - Configure Web server fails
            hyperion start
            Hi John,
            Is this the reason why WORKSPACE does not open when I type in the 38080 URL? Does it have to do with the CONFIGURE WEB SERVER failure. When I try the WORKSPACE URL it says something about registry.
            • 3. Re: Foundation Services - Configure Web server fails
              You need to access workspace through the http web server e.g OHS so if that has failed you will have trouble accessing workspace.


              • 4. Re: Foundation Services - Configure Web server fails
                hyperion start
                As you had suggested, I cleared the logs and then tried to configure Foundation Services, and again the same issue, CONFIGURE WEB SERVER fails.
                I checked the logs and this is what it has (a part of it)
                It says HTTPD.CONF wasn't found. I checked the path, and my file system does not have ohs_component inside the d$\Oracle\Middleware\user_projects\epmsystem1\httpConfig\ohs folder.
                It is an installation after REINSTALLATION. Could it be the problem. How could I get those file, is there any way I can install OHS and solve the problem?
                What would you suggest?
                Thanks again.

                [2013-01-28T16:11:35.733-05:00] [EPMCFG] [TRACE] [EPMCFG-05944] [oracle.EPMCFG] [tid: 18] [ecid: 0000Jm301q_6qIC0ZFM6Vr1H1iU0000004,0] [SRC_CLASS: com.hyperion.foundation.config.HttpServerConfigurator] configure Oracle HTTP Server 2
                [2013-01-28T16:11:35.749-05:00] [EPMCFG] [TRACE] [EPMCFG-01426] [oracle.EPMCFG] [tid: 18] [ecid: 0000Jm301q_6qIC0ZFM6Vr1H1iU0000004,0] [SRC_CLASS: com.hyperion.cis.ant.AbstractAntConfigurator] propertiesExtractLocation : D:\Oracle\Middleware\user_projects\epmsystem1\httpConfig\ant_properties
                [2013-01-28T16:11:41.499-05:00] [EPMCFG] [TRACE] [EPMCFG-01427] [oracle.EPMCFG] [tid: 18] [ecid: 0000Jm301q_6qIC0ZFM6Vr1H1iU0000004,0] [SRC_CLASS: com.hyperion.cis.ant.AbstractAntConfigurator] Executing target: ohs-prepare-config
                [2013-01-28T16:12:24.780-05:00] [EPMCFG] [ERROR] [EPMCFG-07236] [oracle.EPMCFG] [tid: 18] [ecid: 0000Jm301q_6qIC0ZFM6Vr1H1iU0000004,0] [SRC_CLASS: com.hyperion.cis.config.ant.apache2.OHS2Configurator] D:\Oracle\Middleware\user_projects\epmsystem1\httpConfig\ohs/config/OHS/ohs_component/httpd.conf wasn't found. OHS wasnt configured successfully, see oraInventory logs for more details"
                [2013-01-28T16:12:24.780-05:00] [EPMCFG] [ERROR] [EPMCFG-05364] [oracle.EPMCFG] [tid: 18] [ecid: 0000Jm301q_6qIC0ZFM6Vr1H1iU0000004,0] [SRC_CLASS: com.hyperion.foundation.config.WebServerConfigurationTaskProcessor] Error in web server configuring:[[
                com.hyperion.cis.config.HttpConfigurationException: File not found
                • 5. Re: Foundation Services - Configure Web server fails
                  Vivek Chetiaparath
                  Try the following KM article

                  Unable to Configure Oracle HTTP Server (OHS)-- Hyperion Planning (Doc ID 1274289.1)

                  • 6. Re: Foundation Services - Configure Web server fails
                    The document is aimed at AIX so if it is the same problem as it is a windows install it is worth either clearing out the temp directory or setting the temp windows environment variables to a location where there is lots of space like a different drive.