1 Reply Latest reply: Jan 29, 2013 12:38 AM by 987576 RSS

    Problems with configuring and executing Human Tasks, by using Users/Groups.

    987576
      Hi All,

      I have been working with SOA 11g BPEL processes. I developed my own custom worklist application to work up on the human tasks. My application is haveing it's own user management functionality, where i define all USER, GROUPS and ROLES of the application. Now, i have the following questions.

      Q1. How can i access all the users, Groups from my custom application, to display inside JDeveloper. When i am configuring the Human Task. (i.e. When defining the Assignments)? By default, it is reading all Users/Groups from "jazn.com" realm. How should i access users/groups from my custom application database?.

      Q2. After deployng the BPEL process in to SOA Server, when i execute the process at runtime, i am geting the following error. How to solve this?.

      "Error in routing slip. The task is assigned to an invalid group LEVEL_3 in realm jazn.com. The routing slip is associated with the task definition default/CustomerProcess!1.0/Customer_Human_Task. Verify that the group is specified correctly in the routing slip in the task definition."

      here, group "LEVEL_3" is passed dynamically to the human task, through Xpath expression. This is the group, which i defined inside my custom application database. How should i instruct the SOA server to read the User/Groups from my application database instead of from "jazn.com" realm?.


      Follwings are the steps i tried, to solve the above issue, with best of my knowledge. But, i could not succeeded.

      Solution tried: Inside Security Realms --> myrealm --> i created a provider called "SQLAuthenticator", where i configured all SQL queries to my application database. After this, i am able to see all the users/groups inside 'myrealm ' from 'SQLAuthenticator'. And also, i am able to login into SOA weblogic server, by using the usernae/password, which i created inside my custome application. But, i could not succeeded to resolve the above queries. Please help me to solve these issues.

      Thanks & Regards,
      Naga.