This discussion is archived
2 Replies Latest reply: Jan 29, 2013 12:34 PM by Dan at Branchbird RSS

Getting the below error when running the Baseline.grf for the first time

Santosh Kale Newbie
Currently Being Moderated
I am getting the below error when running the Baseline.grf for the first time.
Appreciate your support in resolving it.
Error below:
INFO [main] - *** CloverETL framework/transformation graph, (c) 2002-2012 Javlin a.s, released under GNU Lesser General Public License ***
INFO [main] - Running with CloverETL library version 3.2.1 build#63 compiled 04/01/2012 12:53:21
INFO [main] - Running on 4 CPU(s), OS Windows 7, architecture amd64, Java version 1.6.0_20, max available memory for JVM 901120 KB
INFO [main] - Loading default properties from: defaultProperties
INFO [main] - Graph definition file: graph/Baseline.grf
INFO [main] - Graph revision: 1.114 Modified by: mkressirer Modified: Thu Apr 12 13:27:18 EDT 2012
INFO [main] - Checking graph configuration...
INFO [main] - Graph configuration is valid.
INFO [main] - Graph initialization (Baseline)
INFO [main] - [Clover] Initializing phase: 0
INFO [main] - [Clover] phase: 0 initialized successfully.
INFO [main] - register MBean with name:org.jetel.graph.runtime:type=CLOVERJMX_1306871483270_0
INFO [WatchDog] - Starting up all nodes in phase [0]
INFO [WatchDog] - Successfully started all nodes in phase!
INFO [RUN_GRAPH1_0] - Running graph ./graph/InitDataStore.grf in the same instance.
INFO [RUN_GRAPH1_0] - Checking graph configuration...
INFO [RUN_GRAPH1_0] - Graph configuration is valid.
INFO [RUN_GRAPH1_0] - Graph initialization (InitDataStore)
INFO [RUN_GRAPH1_0] - [Clover] Initializing phase: 0
WARN [RUN_GRAPH1_0] - WS messenger cleanup failed.
java.lang.NullPointerException
     at org.apache.axis2.client.Stub.cleanup(Stub.java:134)
     at com.opensys.cloveretl.component.WebServiceClient.free(Unknown Source)
     at org.jetel.graph.Phase.free(Phase.java:487)
     at org.jetel.graph.TransformationGraph.freeResources(TransformationGraph.java:681)
     at org.jetel.graph.TransformationGraph.free(TransformationGraph.java:955)
     at org.jetel.graph.runtime.PrimitiveAuthorityProxy.executeGraph(PrimitiveAuthorityProxy.java:149)
     at org.jetel.component.RunGraph.runGraphThisInstance(RunGraph.java:511)
     at org.jetel.component.RunGraph.runSingleGraph(RunGraph.java:409)
     at org.jetel.component.RunGraph.execute(RunGraph.java:302)
     at org.jetel.graph.Node.run(Node.java:414)
     at java.lang.Thread.run(Thread.java:619)
WARN [RUN_GRAPH1_0] - Some graphs wasn't executed (because graph "./graph/InitDataStore.grf" finished with error).
WARN [RUN_GRAPH1_0] - Some graph(s) finished with error.
ERROR [WatchDog] - Graph execution finished with error
ERROR [WatchDog] - Node RUN_GRAPH1 finished with status: ERROR caused by: Graph './graph/InitDataStore.grf' failed!
ERROR [WatchDog] - Node RUN_GRAPH1 error details:
org.jetel.exception.JetelException: Graph './graph/InitDataStore.grf' failed!
     at org.jetel.component.RunGraph.execute(RunGraph.java:324)
     at org.jetel.graph.Node.run(Node.java:414)
     at java.lang.Thread.run(Thread.java:619)
INFO [WatchDog] - [Clover] Post-execute phase finalization: 0
INFO [WatchDog] - [Clover] phase: 0 post-execute finalization successfully.
INFO [WatchDog] - Execution of phase [0] finished with error - elapsed time(sec): 2
ERROR [WatchDog] - !!! Phase finished with error - stopping graph run !!!
INFO [WatchDog] - -----------------------** Summary of Phases execution **---------------------
INFO [WatchDog] - Phase# Finished Status RunTime(sec) MemoryAllocation(KB)
INFO [WatchDog] - 0 ERROR 2 20132
INFO [WatchDog] - ------------------------------** End of Summary **---------------------------
WARN [exNode_0_1306871483270_RUN_GRAPH1] - Attempt to unregister non-registered thread in the ContextProvider.
./graph/InitDataStore.grf: Execution of graph failed! Error during graph initialization: Phase 0 can't be initilized.
INFO [WatchDog] - WatchDog thread finished - total execution time: 2 (sec)
INFO [main] - Freeing graph resources.
ERROR [main] - Execution of graph failed !
  • 1. Re: Getting the below error when running the Baseline.grf for the first time
    Chris C Newbie
    Currently Being Moderated
    You may want to attempt just running InitDataStore.grf to get a more helpful error message. It is failing, then passing a failure command up to the wrapper Baseline.grf, but not really logging/passing up any helpful error messages.
  • 2. Re: Getting the below error when running the Baseline.grf for the first time
    Dan at Branchbird Journeyer
    Currently Being Moderated
    It can't find an Endeca specific class when running via the clover command line utility. Thus, the classpath being set in that shell script is not incorporating the .jar files where the endeca-specific classes are packaged. I would start by adding an line to see what your classpath is set to. There are actually already some lines of shell script in clover that you can uncomment to see what .jars are getting loaded:

    #echo $CLOVER_LIB/*

    for i in $CLOVER_LIB/*.jar $CLOVER_LIB/*.zip; do
         LOCAL_CLASSPATH="$LOCAL_CLASSPATH:$i"
    done;

    #for i in `ls $CLOVER_LIB/*.jar`; do
    #echo $i
    #done;

    You could also echo LOCAL_CLASSPATH to see what is getting set there. At the end of the day, you will need the endeca-specific jars to load which can be found here: /Endeca/Discovery/2.3.0/Integrator/plugins/com.endeca.latitude_1.0.0/*

    HTH,
    Dan
    http://branchbird.com

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points