3 Replies Latest reply: Jan 31, 2013 3:07 AM by 901993 RSS

    WebLogic console where OIM is deployed is not accesible

    901993
      Hi All,

      OIM 9.1.0.2 is setup in WebLogic server and we are able to access OIM console http://host:port/xlWebApp and login properly. However the WebLogic server is showing status as up and running in server log. While accessing WebLogic console http://host:port/console , we are getting the below error:

      INFO: Completed initializing Sun's JavaServer Faces implementation (1.2_03-b04-FCS) for context '/console'
      <Jan 28, 2013 10:09:55 AM PST> <Warning> <HTTP> <BEA-101162> <User defined listener com.sun.faces.config.ConfigureListener failed: java.lang.NoClassDefFoundError: javax/xml/parsers/SAXParserFactory.
      java.lang.NoClassDefFoundError: javax/xml/parsers/SAXParserFactory
      at com.sun.faces.config.ConfigureListener$WebXmlProcessor.getConfiguredFactory(ConfigureListener.java:1987)
      at com.sun.faces.config.ConfigureListener$WebXmlProcessor.scanForFacesServlet(ConfigureListener.java:1960)
      at com.sun.faces.config.ConfigureListener$WebXmlProcessor.<init>(ConfigureListener.java:1934)
      at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:300)
      at weblogic.servlet.internal.EventsManager$FireContextListenerAction.run(EventsManager.java:481)
      Truncated. see log file for complete stacktrace

      Caused By: java.lang.ClassNotFoundException: javax.xml.parsers.SAXParserFactory
      at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:296)
      at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:269)
      at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:56)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      Truncated. see log file for complete stacktrace
      >
      <Jan 28, 2013 10:09:55 AM PST> <Error> <Deployer> <BEA-149231> <Unable to set the activation state to true for the application 'consoleapp'.
      weblogic.application.ModuleException:
      at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1399)
      at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:460)
      at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)
      at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:83)
      at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)
      Truncated. see log file for complete stacktrace

      Caused By: java.lang.ClassNotFoundException: javax.xml.parsers.SAXParserFactory
      at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:296)
      at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:269)
      at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:56)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      Truncated. see log file for complete stacktrace
      >
      <Jan 28, 2013 10:09:55 AM PST> <Notice> <Log Management> <BEA-170027> <The Server has established connection with the Domain level Diagnostic Service successfully.>
      <Jan 28, 2013 10:09:56 AM PST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to ADMIN>
      <Jan 28, 2013 10:09:56 AM PST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RESUMING>
      <Jan 28, 2013 10:09:56 AM PST> <Notice> <Server> <BEA-002613> <Channel "Default" is now listening on 10.133.230.36:7001 for protocols iiop, t3, ldap, sn

      Any help is very much appreciated.

      Thanks
      Mahendra.

      Edited by: 898990 on 30-Jan-2013 01:40