This discussion is archived
7 Replies Latest reply: Feb 4, 2013 2:51 AM by raghav1212 RSS

Deployment of ADF App to WebLogic

raghav1212 Newbie
Currently Being Moderated
hi ,

Jdev 11.1.1.6.0 and Web Logic 10.3

When i am trying to deploy my app to the web logic i am getting below error any solutions .

[03:00:11 PM] Weblogic Server Exception: weblogic.management.DeploymentException: [J2EE:160149]Error while processing library references. Unresolved application library references, defined in weblogic-application.xml: [Extension-Name: adf.oracle.domain, exact-match: false], [Extension-Name: oracle.jsp.next, exact-match: false].
[03:00:11 PM] See server logs or server console for more details.
[03:00:11 PM] weblogic.management.DeploymentException: [J2EE:160149]Error while processing library references. Unresolved application library references, defined in weblogic-application.xml: [Extension-Name: adf.oracle.domain, exact-match: false], [Extension-Name: oracle.jsp.next, exact-match: false].
[03:00:12 PM] #### Deployment incomplete. ####
[03:00:12 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)

Thanks
Raghav
  • 1. Re: Deployment of ADF App to WebLogic
    Dimitar Dimitrov Expert
    Currently Being Moderated
    You should extend the WLS domain with ADF Runtime if you have not done that. If the domain is extended with ADF Runtime, check that the library adf.oracle.domain is mapped as a target of the corresponding managed server in the domain.

    Note also that WLS 10.3 is not supported by ADF 11.1.1.6. WLS 10.3.6 is the version supported by ADF 11.1.1.6.

    Dimitar

    Edited by: Dimitar Dimitrov on Jan 30, 2013 12:32 PM
  • 2. Re: Deployment of ADF App to WebLogic
    raghav1212 Newbie
    Currently Being Moderated
    Hi ,

    But the Jdev 11.1.1.6.0 comes with WLS 10.3.5 only with the integrated Jdev it works fine .
  • 3. Re: Deployment of ADF App to WebLogic
    John Stegeman Oracle ACE
    Currently Being Moderated
    Regardless of what comes with JDev, what is supported for ADF 11.1.1.6 is WLS 10.3.6 with the Application Development Runtime 11.1.1.6 installed.
  • 4. Re: Deployment of ADF App to WebLogic
    Joonas Linkola Journeyer
    Currently Being Moderated
    WLS 10.3.5 is also certified and supported with 11.1.1.6, according to the certification matrix: http://www.oracle.com/technetwork/developer-tools/jdev/index-091111.htm
  • 5. Re: Deployment of ADF App to WebLogic
    raghav1212 Newbie
    Currently Being Moderated
    No my question is on Windows i have a Jdeveloper 11.1.1.6.0 with integrated WLS 10.3.5 and it works fine . But the same APP i am trying to deploy on Linux hosted box where i installed the WLS 10.3.5 but there the deploy fails with the above mentioned error. So want a solution for this .

    Thanks
    Raghav
  • 6. Re: Deployment of ADF App to WebLogic
    John Stegeman Oracle ACE
    Currently Being Moderated
    Joonas - thanks for that.

    Raghav - you need to install the Application Development Runtime and make sure your WLS domain is extended with it.
  • 7. Re: Deployment of ADF App to WebLogic
    raghav1212 Newbie
    Currently Being Moderated
    I verified that the dokmain extends adf runtime environment already . but one thing i observed is under my EAR file the weblogic-application.xml is like below . Notecd some duplicates entries but how to avoid these duplicate entries while deplaoying ??

    <application-param>
    <param-name>jps.credstore.migration</param-name>
    <param-value>OVERWRITE</param-value>
    </application-param>
    <application-param>
    <param-name>jps.policystore.migration</param-name>
    <param-value>OVERWRITE</param-value>
    </application-param>
    <listener>
    <listener-class>oracle.adf.share.weblogic.listeners.ADFApplicationLifecycleListener</listener-class>
    </listener>
    <listener>
    <listener-class>oracle.mds.lcm.weblogic.WLLifecycleListener</listener-class>
    </listener>
    <listener>
    <listener-class>oracle.security.jps.wls.listeners.JpsApplicationLifecycleListener</listener-class>
    </listener>
    <listener>
    <listener-class>oracle.security.jps.wls.listeners.JpsAppVersionLifecycleListener</listener-class>
    </listener>
    <library-ref>
    <library-name>adf.oracle.domain</library-name>
    </library-ref>
    <library-ref>
    <library-name>oracle.jsp.next</library-name>
    </library-ref>

    Thanks
    Raghav

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points