This discussion is archived
6 Replies Latest reply: Jan 31, 2013 2:54 AM by Saro RSS

Problem with the Repository service

Saro Explorer
Currently Being Moderated
Hi friends,

In my info admin console web page among the repository service and the integration service, i can see the health of the two services as up.

But when i clicked my repository service individually it showed like

The powercenter repository service is available

But it also showed the below error along with the above line like
the following error occurred while performing a repository action. Error - [pcsf_1007] cannot connect to repository[oracle_BI_DW_Base] because \n[[rep_57071] unable to connect to the repository database. Please check repository agent configuration. Failed to connect to repository service [Oracle_BI_DW_Base].]
But my integration service is up and fine.

Since due to the above error, i couldnt connect with any of my info clients(as repository seems to be down from the above error message)

But my informatica service is up.

Im not sure with this problem, but i remember that my DBA's has overwritten with some snapshots on the DB(that im using with BIAPPS) whether that could be the problem

Since im aware that snapshots also a recent one and it does not have any chances of destroying(my BIAPPS metadata)

Couldnt get with the problem clearly. Kindly help me with this.

Thanks in advance.

Regards,
Saro
  • 1. Re: Problem with the Repository service
    Srini VEERAVALLI Guru
    Currently Being Moderated
    Try to connect the database using command prompt with same repository username and password.
    The issue is with connecting to rep database.. something might gone wrong with tns entry
  • 2. Re: Problem with the Repository service
    Saro Explorer
    Currently Being Moderated
    Svee,

    Thanks for the reply.

    i tried by connecting with that user in toad as well as in putty, it is connecting and i can query in it fine. But not sure with this problem.

    Regards,
    Saro
  • 3. Re: Problem with the Repository service
    Srini VEERAVALLI Guru
    Currently Being Moderated
    How about the same from Informatica box? You need to ensure that tns entry is fine to connect with database.
    Just in case try to restart the Informatica service and see how it works.
  • 4. Re: Problem with the Repository service
    Saro Explorer
    Currently Being Moderated
    Svee,

    Yes you are right, i started this informatica service a long before(but dint stopped it), now when i tried to restart the informatica services, it is starting suddenly and all of a sudden after 5 seconds, it is going down.

    Again i restarted it in services.msc and after that if i refresh(@ the top of services.msc) it means then the informatica service is going down again.

    This problem started again. what could be the fix for this svee.

    Regards,
    Saro
  • 5. Re: Problem with the Repository service
    Veeresh Rayan Journeyer
    Currently Being Moderated
    Hi Saro,

    You would have created one DB user during installation.May be by name INFO_DOMAIN etc.
    Go throgh the user and try to connect to DB using this user.
    I clearly see that you are not able to coonect to reposiroty DB and the problem might be either password of the reposiroty is expired or user accont is locked.

    Check with the DBA's and tell the user name.

    Select * from DBA_USERS.Check for this user the account status is 'expired and locked' or OPEN.

    Regards,
    Veeresh Rayan
  • 6. Re: Problem with the Repository service
    Saro Explorer
    Currently Being Moderated
    Hi Svee,

    The issue is been solved, the problem is my db seems to be out of memory.


    Though we managed to increase the db size(mount point size) and after that bounced back the db and also my local machine where the info is installed.

    Now the services seems to be up and it is running fine.

    Thanks for your time.

    Regards,
    Saro

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points