5 Replies Latest reply: Feb 7, 2013 7:40 AM by ckrig-Oracle RSS

    OBIEE 11.1.1.6.4 XMLViewService Assertions error ACIOA5LN on soaphelpers

    878951
      Hi,

      We use webservices to download the report data in xml format, we used the OBIEE webservices XMLViewService.executeXMLQuery. The code worked just fine till 11.1.1.5 version of OBIEE , recently when we upgraded to 11.1.1.6.4, we faced the issue

      <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:saw-SOAP="com.siebel.analytics.web/soap/v6"> <soap:Body> <soap:Fault><faultcode>soap:Server</faultcode>
      <faultstring>Assertion failure: false at line 141 of C:\ADE\aime_4\bifndn\analytics_web\main/project/websoap/soaphelpers.cpp</faultstring>
      <detail><sawsoape:Error xmlns:sawsoape="com.siebel.analytics.web/soap/error/v1">
      <sawsoape:Code>ACIOA5LN</sawsoape:Code>
      <sawsoape:Message>Assertion failure: false at line 141 of C:\ADE\aime_4\bifndn\analytics_web\main/project/websoap/soaphelpers.cpp</sawsoape:Message>
      <sawsoape:File>main/project/websoap/soaphelpers.cpp</sawsoape:File>
      <sawsoape:Line>141</sawsoape:Line>

      </sawsoape:Error>
      </detail>
      </soap:Fault></soap:Body> </soap:Envelope>

      The above issue happens only when the report has any filterexpressions applied on it. Without Filter expressions the webservice works fine. Any help here is sincerely appreciated.

      Thanks,
      Kumaran.
        • 1. Re: OBIEE 11.1.1.6.4 XMLViewService Assertions error ACIOA5LN on soaphelpers
          878951
          Hi,

          Any help here is greatly appreciated.

          Regards,
          Kumaran.
          • 2. Re: OBIEE 11.1.1.6.4 XMLViewService Assertions error ACIOA5LN on soaphelpers
            ckrig-Oracle
            Hi,

            Bumping as we're experiencing the same problem here.

            Anyone?

            --cb                                                                                                                                                                                   
            • 3. Re: OBIEE 11.1.1.6.4 XMLViewService Assertions error ACIOA5LN on soaphelpers
              Kishore Rout
              Hi,
              There is known bug for this issue in OBIEE 11.1.1.6.2 to OBIEE 11.1.1.6.4 version.

              Bug 14351306 - SHOW DATA AS PERCENTAGE OF GENERATES ERROR AFTER APPLYING 11.1.1.6.2 BP1.

              Please see below metalink id for more information:
              OBIEE 11g: Error: "Assertion failure at line 324 of C:\ADE\aime_1\bifndn\analytics_web\main/inc\nq/webutil/stringenummap.h...Error Codes: ACIOA5LN" when Changing Show Data as Value [ID 1500327.1]

              Mark if this helps

              Regards,
              Kishore
              • 4. Re: OBIEE 11.1.1.6.4 XMLViewService Assertions error ACIOA5LN on soaphelpers
                ckrig-Oracle
                Hi,

                I think these are different problems. Original post states "Assertion failure: false at line 141 of ./project/websoap/soaphelpers.cpp", we're consistently getting the exact same error message on an 11.1.1.6.6 platform.

                <v6:reportParams>
                <v6:filterExpressions>
                <sawx:expr xsi:type="sawx:list" op="beginsWith"
                          xmlns:xsd="http://www.w3.org/2001/XMLSchema/"
                          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance/"
                          xmlVersion="201201160"
                          xmlns:saw="com.siebel.analytics.web/report/v1.1"
                          xmlns:sawx="com.siebel.analytics.web/expression/v1.1">
                     <sawx:expr xsi:type="sawx:sqlExpression">Table.Column</sawx:expr>
                     <sawx:expr xsi:type="xsd:string">123456</sawx:expr>
                </sawx:expr>
                </v6:filterExpressions>
                ...
                <v6:reportParams>

                --cb                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
                • 5. Re: OBIEE 11.1.1.6.4 XMLViewService Assertions error ACIOA5LN on soaphelpers
                  ckrig-Oracle
                  Reaching here, but passing filterExpressions as CDATA at least rids the error message, but the filter does not get applied (result is full data set, just as if filter had not been supplied);

                  <v6:reportParams>
                  <v6:filterExpressions><![CDATA[
                  <sawx:expr xsi:type="sawx:list" op="beginsWith"
                  xmlns:xsd="http://www.w3.org/2001/XMLSchema/"
                  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance/"
                  xmlVersion="201201160"
                  xmlns:saw="com.siebel.analytics.web/report/v1.1"
                  xmlns:sawx="com.siebel.analytics.web/expression/v1.1">
                  <sawx:expr xsi:type="sawx:sqlExpression">Table.Column</sawx:expr>
                  <sawx:expr xsi:type="xsd:string">123456</sawx:expr>
                  </sawx:expr>]]></v6:filterExpressions>
                  ...
                  <v6:reportParams>

                  --cb