This discussion is archived
3 Replies Latest reply: Feb 3, 2013 3:33 AM by user503699 RSS

yum update fails on oel 4

user503699 Expert
Currently Being Moderated
Hello,

I have a virtual machine set up with OEL4 and Oracle Database 9iR2 installed on it quite a while back. All had worked well at the time of setup.
Couple of days back, I decided to update the OS and ran "yum update" with yum pointing to "el4_latest" repository on oracle public yum server.
However, the "yum update" fails with a transaction error.
I am a newbie with Linux and so am looking for help to figure out what is causing this error and how to resolve it.
Following are the details, I feel are relevant to my problem but let me know if you need any more details.
The error message:
[oracle@localhost ~]$ cat Desktop/yumupdateerror.log
Transaction Check Error:   file /usr/lib/libdaplcma.so.1.0.2 conflicts between attempted installs of compat-dapl-1.2.5-2.0.7-2.el4 and compat-dapl-2.0.15-1.el4
  file /usr/lib/libdat.so.1.0.2 conflicts between attempted installs of compat-dapl-1.2.5-2.0.7-2.el4 and compat-dapl-2.0.15-1.el4
The details of the OS
[oracle@localhost ~]$ lsb_release -a
LSB Version:    :core-3.0-ia32:core-3.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch
Distributor ID: EnterpriseEnterpriseAS
Description:    Enterprise Linux Enterprise Linux AS release 4 (October Update 5)
Release:        4
Codename:       OctoberUpdate5
[oracle@localhost ~]$ uname -r
2.6.9-55.0.0.0.2.ELsmp
[oracle@localhost ~]$ rpm -qa | grep kernel
kernel-smp-2.6.9-55.0.0.0.2.EL
kernel-utils-2.4-13.1.99.0.1
kernel-devel-2.6.9-55.0.0.0.2.EL
kernel-2.6.9-55.0.0.0.2.EL
kernel-hugemem-devel-2.6.9-55.0.0.0.2.EL
kernel-smp-devel-2.6.9-55.0.0.0.2.EL
[oracle@localhost ~]$ rpm -qa | grep compat
compat-libstdc++-296-2.96-132.7.2
compat-libgcc-296-2.96-132.7.2
compat-libcom_err-1.0-5
compat-openldap-2.1.30-7.4E
java-1.4.2-gcj-compat-1.4.2.0-27jpp
compat-gcc-32-c++-3.2.3-47.3
compat-libcwait-2.1-1
compat-libstdc++-33-3.2.3-47.3
compat-db-4.1.25-9
compat-gcc-32-3.2.3-47.3
Thanks in advance.
  • 1. Re: yum update fails on oel 4
    Dude! Guru
    Currently Being Moderated
    I suggest to check the release notes: https://oss.oracle.com/el4/docs/RELEASE-NOTES-U8-en.html which mentions a known problem that might apply.

    What happens if you try "yum install compat-dapl" prior to using yum update?
  • 2. Re: yum update fails on oel 4
    user503699 Expert
    Currently Being Moderated
    Dude wrote:
    I suggest to check the release notes: https://oss.oracle.com/el4/docs/RELEASE-NOTES-U8-en.html, which mentions a known problem that might apply.
    Dude,

    Thanks for the response and the link above. But it gives a "404 Not found".
    What happens if you try "yum install compat-dapl" prior to using yum update?
    Now, why did not I think of that clever idea? You were spot on!!!
    When I installed compat-dapl separately and subsequently ran yum update, everything worked well.
    In the process, I also managed to resolve my original issue (not mentioned here) but yum update looks like a sledgehammer approach to crack the nut.

    I have a feeling just updating/adding few packages may have resolved the issue (without having to update the kernel itself, caused by yum update) and discussing it with experts like yourself would have added to my knowledge about linux.
    But that issue had virtualbox in the picture and so I was worried some over-active moderator would have blocked my thread and redirected me to virtualbox forum.
    ;)

    Anyway, Thanks once again for your help with this.
  • 3. Re: yum update fails on oel 4
    Dude! Guru
    Currently Being Moderated
    Thanks for the feedback! I fixed the link - it was a silly comma (,) at the end of the url ;-)

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points