3 Replies Latest reply: Feb 4, 2013 1:51 AM by saurabh RSS

    Unable to run export command invalid username and password

    979251
      i am trying to run export command to export the complete database but i am getting error of invalid user name and password


      command

      from root i am switching to
      su- oracle

      exp oracle/12345 file=03-2-2013BackupDB.dmp log=backuplog.log

      ORA-01017: invalid username/password; logon denied

      but when i use to login through putty it gives no error

      oracle
      12345

      maybe i am doing something wrong sorry as i am newbie in oracle world

      oracle 11gR2
      Suselinux

      Please help..................
        • 1. Re: Unable to run export command invalid username and password
          Srini Chavali-Oracle
          When you log in thru a tool like putty, you are logging in to the OS user "oracle". For exp, you need to specify a database account (such as SYSTEM) and password of that database account.

          With 11gR2, original export is desupported - http://docs.oracle.com/cd/E11882_01/server.112/e22490/original_export.htm#BABBHCIE

          You should be using expdp. If you are exporting for backup purposes, pl note that exports are not backups, you should be using RMAN

          http://docs.oracle.com/cd/E11882_01/backup.112/e10642/rcmintro.htm#CHDBHGGE

          HTH
          Srini
          • 2. Re: Unable to run export command invalid username and password
            979251
            Thank you so much Srini

            can you please tell me how i change my database mode in archive as current my database in noarchive mode means i cannot take backup using RMAN utility
            please tell me the complete steps to change my mode successfully
            • 3. Re: Unable to run export command invalid username and password
              saurabh
              to make your database in archive log mode you need to give a downtime of your database for this you can do following steps.

              if you are using spfile

              1. shutdown the database.

              2. startup in mount mode

              3. use command 'alter database archivelog';

              4. specify the archive log location using command
              ' alter system set log_archive_dest_1='LOCATION=location_path';'

              5. specify archive log format as
              'alter system set archive_log_format=your choice;'

              6. enable the archive log dest using ' alter system set log_archive_dest_state_1=enable;'