This discussion is archived
4 Replies Latest reply: Feb 12, 2013 7:02 AM by Suresh KB RSS

managed server not starting

adf009 Explorer
Currently Being Moderated
hi am using WebLogic Server Version: 10.3.6.0 i created a managed server but when i try to start it am geting below error
 
C:\Oracle\weblogic10.3.6.0\user_projects\domains\base_domain\bin>startManagedWebLogic.cmd UAMDevOrganisation
.
.
JAVA Memory arguments: -Xms256m -Xmx512m -XX:CompileThreshold=8000 -XX:PermSize=128m  -XX:MaxPermSize=512m
.
WLS Start Mode=Development
.
CLASSPATH=C:\Oracle\WEBLOG~1.0\ORACLE~1\modules\oracle.jdbc_11.1.1\ojdbc6dms.jar;C:\Oracle\WEBLOG~1.0\patch_wls1036\profiles\default\sys_man
ifest_classpath\weblogic_patch.jar;C:\Oracle\WEBLOG~1.0\patch_ocp371\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MI
DDLE~2\JDK160~1\lib\tools.jar;C:\Oracle\WEBLOG~1.0\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\WEBLOG~1.0\WLSERV~1.3\server\lib\weblogic
.jar;C:\Oracle\WEBLOG~1.0\modules\features\weblogic.server.modules_10.3.6.0.jar;C:\Oracle\WEBLOG~1.0\WLSERV~1.3\server\lib\webservices.jar;C
:\Oracle\WEBLOG~1.0\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Oracle\WEBLOG~1.0\modules\NETSFA~1.0_1/lib/ant-contrib.jar;C:\Oracle\WEBLOG~1.0\OR
ACLE~1\soa\modules\commons-cli-1.1.jar;C:\Oracle\WEBLOG~1.0\ORACLE~1\soa\modules\oracle.soa.mgmt_11.1.1\soa-infra-mgmt.jar;C:\Oracle\WEBLOG~
1.0\ORACLE~1\modules\oracle.jrf_11.1.1\jrf.jar;C:\Oracle\WEBLOG~1.0\WLSERV~1.3\common\derby\lib\derbyclient.jar;C:\Oracle\WEBLOG~1.0\WLSERV~
1.3\server\lib\xqrl.jar
.
PATH=C:\Oracle\WEBLOG~1.0\patch_wls1036\profiles\default\native;C:\Oracle\WEBLOG~1.0\patch_ocp371\profiles\default\native;C:\Oracle\WEBLOG~1
.0\WLSERV~1.3\server\native\win\x64;C:\Oracle\WEBLOG~1.0\WLSERV~1.3\server\bin;C:\Oracle\WEBLOG~1.0\modules\ORGAPA~1.1\bin;C:\Oracle\MIDDLE~
2\JDK160~1\jre\bin;C:\Oracle\MIDDLE~2\JDK160~1\bin;C:\OracleClient32;C:\app\10017134\product\11.2.0\dbhome_1\BIN;C:\DevSuiteHome\jdk\jre\bin
\classic;C:\DevSuiteHome\jdk\jre\bin;C:\DevSuiteHome\jdk\jre\bin\client;C:\DevSuiteHome\jlib;C:\DevSuiteHome\bin;C:\DevSuiteHome\jre\1.4.2\b
in\client;C:\DevSuiteHome\jre\1.4.2\bin;C:\DevSuiteHome;C:\app\10017134\product\11.2.0\dbhome_1;C:\Windows\System32;C:\Windows;C:\DevSuiteHo
me\BIN;C:\app\10017134\product\11.2.0\dbhome_1\NETWORK\ADMIN;C:\Oracle\Middleware\jdk160_24;C:\Oracle\WEBLOG~1.0\WLSERV~1.3\server\native\wi
n\x64\oci920_8
.
***************************************************
*  To start WebLogic Server, use a username and   *
*  password assigned to an admin-level user.  For *
*  server administration, use the WebLogic Server *
*  console at http:\\hostname:port\console        *
***************************************************
starting weblogic with Java version:
java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b50)
Java HotSpot(TM) Client VM (build 19.1-b02, mixed mode)
Starting WLS with line:
C:\Oracle\MIDDLE~2\JDK160~1\bin\java -client   -Xms256m -Xmx512m -XX:CompileThreshold=8000 -XX:PermSize=128m  -XX:MaxPermSize=512m -Dweblogi
c.Name=UAMDevOrganisation -Djava.security.policy=C:\Oracle\WEBLOG~1.0\WLSERV~1.3\server\lib\weblogic.policy -Dweblogic.security.SSL.trustedC
AKeyStore="C:\Oracle\weblogic10.3.6.0\wlserver_10.3\server\lib\cacerts"  -Xverify:none  -da -Dplatform.home=C:\Oracle\WEBLOG~1.0\WLSERV~1.3
-Dwls.home=C:\Oracle\WEBLOG~1.0\WLSERV~1.3\server -Dweblogic.home=C:\Oracle\WEBLOG~1.0\WLSERV~1.3\server  -Dcommon.components.home=C:\Oracle
\WEBLOG~1.0\ORACLE~1 -Djrf.version=11.1.1 -Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.Jdk14Logger -Ddomain.home=C:\Orac
le\WEBLOG~1.0\USER_P~1\domains\BASE_D~1 -Djrockit.optfile=C:\Oracle\WEBLOG~1.0\ORACLE~1\modules\oracle.jrf_11.1.1\jrocket_optfile.txt -Dorac
le.server.config.dir=C:\Oracle\WEBLOG~1.0\USER_P~1\domains\BASE_D~1\config\FMWCON~1\servers\UAMDevOrganisation -Doracle.domain.config.dir=C:
\Oracle\WEBLOG~1.0\USER_P~1\domains\BASE_D~1\config\FMWCON~1  -Digf.arisidbeans.carmlloc=C:\Oracle\WEBLOG~1.0\USER_P~1\domains\BASE_D~1\conf
ig\FMWCON~1\carml  -Digf.arisidstack.home=C:\Oracle\WEBLOG~1.0\USER_P~1\domains\BASE_D~1\config\FMWCON~1\arisidprovider -Doracle.security.jp
s.config=C:\Oracle\WEBLOG~1.0\USER_P~1\domains\BASE_D~1\config\fmwconfig\jps-config.xml -Doracle.deployed.app.dir=C:\Oracle\WEBLOG~1.0\USER_
P~1\domains\BASE_D~1\servers\UAMDevOrganisation\tmp\_WL_user -Doracle.deployed.app.ext=\- -Dweblogic.alternateTypesDirectory=C:\Oracle\WEBLO
G~1.0\ORACLE~1\modules\oracle.ossoiap_11.1.1,C:\Oracle\WEBLOG~1.0\ORACLE~1\modules\oracle.oamprovider_11.1.1 -Djava.protocol.handler.pkgs=or
acle.mds.net.protocol  -Dweblogic.jdbc.remoteEnabled=false  -Dem.oracle.home=C:\Oracle\weblogic10.3.6.0\oracle_common -Djava.awt.headless=tr
ue -Dweblogic.management.discover=false -Dweblogic.management.server=http://server:7001  -Dwlw.iterativeDev=false -Dwlw.testConsole=fal
se -Dwlw.logErrorsToConsole=false -Dweblogic.ext.dirs=C:\Oracle\WEBLOG~1.0\patch_wls1036\profiles\default\sysext_manifest_classpath;C:\Oracl
e\WEBLOG~1.0\patch_ocp371\profiles\default\sysext_manifest_classpath  weblogic.Server
<05 Feb 2013 11:37:39 AM> <Info> <Security> <BEA-090905> <Disabling CryptoJ JCE Provider self-integrity check for better startup performance
. To enable this check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true>
<05 Feb 2013 11:37:39 AM> <Info> <Security> <BEA-090906> <Changing the default Random Number Generator in RSA CryptoJ from ECDRBG to FIPS186
PRNG. To disable this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true>
<05 Feb 2013 11:37:39 AM> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) Client VM Version 19.1-b02 fr
om Sun Microsystems Inc.>
<05 Feb 2013 11:37:39 AM> <Info> <Management> <BEA-141107> <Version: WebLogic Server 10.3.6.0  Tue Nov 15 08:52:36 PST 2011 1441050 >
<05 Feb 2013 11:37:40 AM> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
<05 Feb 2013 11:37:40 AM> <Info> <WorkManager> <BEA-002900> <Initializing self-tuning thread pool>
<05 Feb 2013 11:37:40 AM> <Notice> <LoggingService> <BEA-320400> <The log file C:\Oracle\weblogic10.3.6.0\user_projects\domains\base_domain\
servers\UAMDevOrganisation\logs\UAMDevOrganisation.log will be rotated. Reopen the log file if tailing has stopped. This can happen on some
platforms like Windows.>
<05 Feb 2013 11:37:40 AM> <Notice> <LoggingService> <BEA-320401> <The log file has been rotated to C:\Oracle\weblogic10.3.6.0\user_projects\
domains\base_domain\servers\UAMDevOrganisation\logs\UAMDevOrganisation.log00004. Log messages will continue to be logged in C:\Oracle\weblog
ic10.3.6.0\user_projects\domains\base_domain\servers\UAMDevOrganisation\logs\UAMDevOrganisation.log.>
<05 Feb 2013 11:37:40 AM> <Notice> <Log Management> <BEA-170019> <The server log file C:\Oracle\weblogic10.3.6.0\user_projects\domains\base_
domain\servers\UAMDevOrganisation\logs\UAMDevOrganisation.log is opened. All server side log events will be written to this file.>
<05 Feb 2013 11:37:40 AM> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason: The server's administration channel conflicts wit
h the admin server's>
<05 Feb 2013 11:37:40 AM> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
<05 Feb 2013 11:37:40 AM> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down>
<05 Feb 2013 11:37:40 AM> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>
Edited by: adf009 on 2013/02/05 12:45 PM
  • 1. Re: managed server not starting
    sharmela-Oracle Expert
    Currently Being Moderated
    A conflict between the server port and the default administration port is causing the server not to start reflected by this error messages.

    Basically two processes are trying to use the same port and even though it is not clearly specified in the WLS documentation, every server uses port 9002 as administration port by default.
    This issue can be resolved by changing the "Local Administration Port Override:" of the conflicting server to a different value for each server in the same machine:

    Log in to the Admin Console
    Expand 'Environment->Servers'
    Select the appropriate server
    In the 'General' tab, expand the advanced option
    Change the value of: 'Local Administration Port Override:'
  • 2. Re: managed server not starting
    Kalyan Pasupuleti-Oracle Expert
    Currently Being Moderated
    Hi,

    As sharmela mentioned you need place different administrator port on your managed server.

    Goto Admin Console and click on managed server and there under configuration --> Advance..... there you will find Local Administration Port Override: 9002 which is get conflict with AdminServer change this one and restart it again.

    It will solve your problem.

    Regards,
    Kal
  • 3. Re: managed server not starting
    985927 Newbie
    Currently Being Moderated
    I can't open the Admin Consle http://localhost:7001/console


    "
    Internet Explorer cannot display the webpage
    "
  • 4. Re: managed server not starting
    Suresh KB Newbie
    Currently Being Moderated
    If you cannot ccess admin console or start admin server, You can either update the port information or set administration port enabled as "false" in the config/config.xml and restart admin server.

    <administration-port-enabled>false</administration-port-enabled>

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points