2 Replies Latest reply: Feb 5, 2013 2:42 PM by spuchc RSS

    LOV - Display Extra Values in 4.2 Not working

    spuchc
      Our DBA's upgraded our Apex Apps from 3.2 to 4.2 in a development Environment and one issue I see is in the LOV and that the Dispaly Extra values is not working.

      In 3.2, I have "Display Extra Values" set to Yes and it's appears on the page a blank option on the list.
      In 4.2, with the setting still at Yes, the blank item no longer appears on the pick list and the lov is defaulting to the first item in the lov.

      For example in 3.2 it would appear.
      Individual
      Company
      <--- Blank with this be the once shown on the page forcing the user to pick something.

      in 4.2
      Indiviudal <-- with this showing as the selected choice with no blank choice available.
      Company

      Is there something new I have to do?
      Thanks.
        • 1. Re: LOV - Display Extra Values in 4.2 Not working
          Kofi
          Hi <friendly user name>
          I think I am missing something here. "Display Extra Values" will display a value if that value is not in your list of values. So say your LOV had "A", "B" and "C" and you had a value of "D" in your table, then "D" would show only with "Display Extra Values" set to "Yes". At least that is my understanding of the functionality.
          So are you talking about "Display Null Value" instead?
          Kofi
          • 2. Re: LOV - Display Extra Values in 4.2 Not working
            spuchc
            Hi,
            My LOV is a Static LOV that I defined within the application that has a set of values, and in 3.2 when I set the Display extra values to "yes" it gave me a blank choice which it defaulted to which I wanted.
            But in 4.2 it doesn't do that, the help text for display extra values is the same in 3.2 and 4.2 which I read about values that aren't in your table.

            But most of my LOV are static and all have the blank row appearing in 3.2, so I'm confused how it ever worked in 3.2 then.
            Display null is set to No, just like it was in 3.2

            Edited by: spuchc on Feb 5, 2013 3:42 PM