1 Reply Latest reply: Feb 6, 2013 2:49 AM by 986938 RSS

    unable to ssh after upgrade to Solaris 11.1

    986938
      I just upgraded to Solaris 11.1 from Solaris 11 Express on file server after a motherboard failure, (getting 500+ GB of data off a mirror zpool is a sore subject, i.e. kernel panic on zpool import -f .... finally found zpool import -f readonly=on allowed me to get at the data).

      Anyway, I used to be able to ssh from my iMac running 10.6.8 / Darwin 10.8 to my Solaris file server when it was running Solaris 11 Express. Since upgrading to Solaris 11.1, an ssh asks for a password, like it did before w/ Solaris 11 Express, but the password get rejected now.

      I did an ssh -vvv <my file server>. After it prompts for a password and I enter the valid password, it responds with the following on my iMac:
      Password:
      debug3: packet_send2: adding 32 (len 22 padlen 10 extra_pad 64)
      debug1: Authentications that can continue: gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive
      debug3: start over, passed a different list gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive
      debug3: preferred publickey,keyboard-interactive,password
      debug3: authmethod_lookup publickey
      debug3: remaining preferred: keyboard-interactive,password
      debug3: authmethod_lookup keyboard-interactive
      debug3: remaining preferred: password
      debug3: authmethod_is_enabled keyboard-interactive
      debug1: Next authentication method: keyboard-interactive
      debug2: userauth_kbdint
      debug2: we sent a keyboard-interactive packet, wait for reply
      debug2: input_userauth_info_req
      debug2: input_userauth_info_req: num_prompts 1
      Password:


      I have a 2nd Solaris system that I also recently upgraded to Solaris 11.1. I can successfully ssh to it from my iMac. Additionally, an ssh from that 2nd Solaris system to my file server also fails.

      The only difference between my Solaris 11.1 based file server and that 2nd Solaris 11.1 system is the Solaris 11.1 file server is configured with a static IP address where the other is configured with DHCP.

      Am I missing something obvious?

      I'm also having trouble getting a CIFS config to work (again) on that file server too. But, that's a different discussion.