This discussion is archived
2 Replies Latest reply: Feb 6, 2013 8:20 AM by 989502 RSS

can't install pkg install solarisstudio-123

989502 Newbie
Currently Being Moderated
Hi,
I'm new at Solaris (11, x86) and I try to install the Solaris Studio to get the C-compiler.

I followed all steps given by oracles website:

create certificate,
install it,
sudo pkg set-publisher \
     -k /var/pkg/ssl/Oracle_Solaris_Studio.key.pem \
     -c /var/pkg/ssl/Oracle_Solaris_Studio.certificate.pem \
     -G '*' -g https://pkg.oracle.com/solarisstudio/release solarisstudio

everything looks fine, but if I run

"pkg install solarisstudio-123 (or 122)"
it looks like:

# pkg install solarisstudio-123
Creating Plan |pkg: No solution was found to satisfy constraints

what could I do? Thanks a lot for your help!

Here the output of install -v:

Creating Plan |pkg: No solution was found to satisfy constraints
package solver error
attempted operation: install
proposed pkgs:
developer/solarisstudio-123
pkg://solarisstudio/developer/solarisstudio-123@12.3,5.11-1.0.0.0:20120213T143354Z
require: developer/solarisstudio-123/library/perflib@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/library/perflib@12.3,5.11-1.0.0.0:20120213T144620Z because: Suitable required dependency pkg:/system/library/math@0.5.11,5.11-0.174.0.0.0.0.0 cannot be found
require: developer/solarisstudio-123/dbx@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/dbx@12.3,5.11-1.0.0.0:20120213T143948Z because: Suitable required dependency pkg:/developer/solarisstudio-123/backend@12.3,5.11-1.0.0.0 cannot be found
require: developer/solarisstudio-123/library/oic-libs@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/library/oic-libs@12.3,5.11-1.0.0.0:20120213T144155Z because: Suitable required dependency pkg:/library/unixodbc@2.3.0,5.11-0.175.0.0.0.2.537 cannot be found
require: developer/solarisstudio-123/studio-zhCN@12.3,5.11-1.0.0.0
Requires one of: pkg://solarisstudio/developer/solarisstudio-123/studio-zhCN@12.3,5.11-1.0.0.0:20120213T145023Z
require: developer/solarisstudio-123/library/f90-libs@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/library/f90-libs@12.3,5.11-1.0.0.0:20120213T144122Z because: Suitable required dependency pkg:/system/library/math@0.5.11,5.11-0.174.0.0.0.0.0 cannot be found
require: developer/solarisstudio-123/oic@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/oic@12.3,5.11-1.0.0.0:20120213T144940Z because: Suitable required dependency pkg:/system/library@0.5.11,5.11-0.175.0.0.0.2.1 cannot be found
require: developer/solarisstudio-123/library/math-libs@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/library/math-libs@12.3,5.11-1.0.0.0:20120213T144152Z because: Suitable required dependency pkg:/system/library/math@0.5.11,5.11-0.174.0.0.0.0.0 cannot be found
require: developer/solarisstudio-123/studio-ja@12.3,5.11-1.0.0.0
Requires one of: pkg://solarisstudio/developer/solarisstudio-123/studio-ja@12.3,5.11-1.0.0.0:20120213T145018Z
require: developer/solarisstudio-123/dmake@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/dmake@12.3,5.11-1.0.0.0:20120213T144019Z because: Suitable required dependency pkg:/system/library/math@0.5.11,5.11-0.174.0.0.0.0.0 cannot be found
require: developer/solarisstudio-123/studio-common@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/studio-common@12.3,5.11-1.0.0.0:20120213T144959Z because: Suitable required dependency pkg:/system/library@0.5.11,5.11-0.175.0.0.0.2.1 cannot be found
require: developer/solarisstudio-123/studio-legal@12.3,5.11-1.0.0.0
Requires one of: pkg://solarisstudio/developer/solarisstudio-123/studio-legal@12.3,5.11-1.0.0.0:20120213T145022Z
require: developer/solarisstudio-123/library/c++-libs@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/library/c++-libs@12.3,5.11-1.0.0.0:20120213T144111Z because: Suitable required dependency pkg:/system/library/math@0.5.11,5.11-0.174.0.0.0.0.0 cannot be found
require: developer/solarisstudio-123/studio-ide@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/studio-ide@12.3,5.11-1.0.0.0:20120213T145003Z because: Suitable required dependency pkg:/developer/solarisstudio-123/studio-common@12.3,5.11-1.0.0.0 cannot be found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/studio-ide@12.3,5.11-1.0.1.0:20120619T172948Z because: Suitable required dependency pkg:/developer/solarisstudio-123/studio-common@12.3,5.11-1.0.0.0 cannot be found
require: developer/solarisstudio-123/code-analyzer@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/code-analyzer@12.3,5.11-1.0.0.0:20120213T143938Z because: Suitable required dependency pkg:/shell/bash@4.1.9,5.11-0.175.0.0.0.2.537 cannot be found
require: developer/solarisstudio-123/fortran@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/fortran@12.3,5.11-1.0.0.0:20120213T144022Z because: Suitable required dependency pkg:/developer/solarisstudio-123/backend@12.3,5.11-1.0.0.0 cannot be found
require: developer/solarisstudio-123/dbxtool@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/dbxtool@12.3,5.11-1.0.0.0:20120213T144012Z because: Suitable required dependency pkg:/developer/solarisstudio-123/studio-common@12.3,5.11-1.0.0.0 cannot be found
require: developer/solarisstudio-123/dlight@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/dlight@12.3,5.11-1.0.0.0:20120213T144017Z because: Suitable required dependency pkg:/developer/solarisstudio-123/studio-common@12.3,5.11-1.0.0.0 cannot be found
require: developer/solarisstudio-123/analyzer@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/analyzer@12.3,5.11-1.0.0.0:20120213T143354Z because: Suitable required dependency pkg:/diagnostic/cpu-counters@0.5.11,5.11-0.175.0.0.0.2.1 cannot be found
require: developer/solarisstudio-123/backend@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/backend@12.3,5.11-1.0.0.0:20120213T143409Z because: Suitable required dependency pkg:/system/library/math@0.5.11,5.11-0.174.0.0.0.0.0 cannot be found
require: developer/solarisstudio-123/cc@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/cc@12.3,5.11-1.0.0.0:20120213T143930Z because: Suitable required dependency pkg:/developer/solarisstudio-123/backend@12.3,5.11-1.0.0.0 cannot be found
require: developer/solarisstudio-123/c++@12.3,5.11-1.0.0.0
FAIL: No matching packages found
Ruled out pkg://solarisstudio/developer/solarisstudio-123/c++@12.3,5.11-1.0.0.0:20120213T143451Z because: Suitable required dependency pkg:/system/library/math@0.5.11,5.11-0.174.0.0.0.0.0 cannot be found
maintained incorporations:
pkg://solaris/consolidation/gfx/gfx-incorporation@0.5.11,5.11-0.151.0.1:20101105T053408Z
pkg://solaris/consolidation/man/man-incorporation@0.5.11,5.11-0.151.0.1:20101105T053412Z
pkg://solaris/consolidation/admin/admin-incorporation@0.5.11,5.11-0.151.0.1:20101105T053405Z
pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.151.0.1:20101105T053417Z
pkg://solaris/consolidation/ub_javavm/ub_javavm-incorporation@0.5.11,5.11-0.151.0.1:20101105T053418Z
pkg://solaris/consolidation/solaris_re/solaris_re-incorporation@0.5.11,5.11-0.151.0.1:20101105T053416Z
pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.151.0.1:20101105T053405Z
pkg://solaris/consolidation/jdmk/jdmk-incorporation@0.5.11,5.11-0.151.0.1:20101105T053410Z
pkg://solaris/consolidation/nvidia/nvidia-incorporation@0.5.11,5.11-0.151.0.1:20101105T053413Z
pkg://solaris/consolidation/dbtg/dbtg-incorporation@0.5.11,5.11-0.151.0.1:20101105T053407Z
pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.151.0.1:20101104T230644Z
pkg://solaris/consolidation/cde/cde-incorporation@0.5.11,5.11-0.151.0.1:20101105T053406Z
pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.151.0.1:20101104T230646Z
pkg://solaris/consolidation/vpanels/vpanels-incorporation@0.5.11,5.11-0.151:20101026T180325Z
pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.151.0.1:20101105T053411Z
pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.151:20101026T180326Z
pkg://solaris/consolidation/sic_team/sic_team-incorporation@0.5.11,5.11-0.151.0.1:20101105T053415Z
pkg://solaris/consolidation/hcts/hcts-incorporation@0.5.11,5.11-0.151.0.1:20101105T053410Z
pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.151.0.1:20101105T053416Z
pkg://solaris/entire@0.5.11,5.11-0.151.0.1:20101105T054056Z
pkg://solaris/consolidation/cns/cns-incorporation@0.5.11,5.11-0.151.0.1:20101105T053407Z
pkg://solaris/consolidation/nspg/nspg-incorporation@0.5.11,5.11-0.151.0.1:20101105T053413Z
pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.151.0.1:20101104T230640Z
pkg://solaris/consolidation/gnome_l10n/gnome_l10n-incorporation@0.5.11,5.11-0.151.0.1:20101105T053408Z
pkg://solaris/consolidation/gnome/gnome-incorporation@0.5.11,5.11-0.151.0.1:20101105T053409Z
pkg://solaris/consolidation/xvm/xvm-incorporation@0.5.11,5.11-0.151.0.1:20101105T053418Z
pkg://solaris/consolidation/sfw/sfw-incorporation@0.5.11,5.11-0.151.0.1:20101105T053414Z
  • 1. Re: can't install pkg install solarisstudio-123
    Alan_S Explorer
    Currently Being Moderated
    The clue is here:

    Suitable required dependency pkg:/system/library/math@0.5.11,5.11-0.174.0.0.0.0.0

    The version string of this library includes the OS component 0.174, which is part of the Solaris 11 11/11 release.

    The output further shows that you are this level:

    pkg://solaris/entire@0.5.11,5.11-0.151.0.1:20101105T054056Z

    This is Solaris 11 Express, which is no longer supported. The release notes for Studio state that Solaris 11 (not Express) is a requirement. See:

    http://docs.oracle.com/cd/E24457_01/html/E21986/ossrn.html#scrolltoc :

         
    Solaris 10 10/08 and subsequent Solaris 10 updates

    Solaris 11 and subsequent Solaris 11 updates

    You would need to update to a supported version of Solaris 11 (Solaris 11.1 is the latest) first.

    That being said, the GCC compiler should be available to you in Solaris 11 Express. You can run "pkg list -af gcc-3" to see what may be available in the repository you are pointing to.


    -- Alan
  • 2. Re: can't install pkg install solarisstudio-123
    989502 Newbie
    Currently Being Moderated
    wrongt solaris version installed: solaris 11 express instead of 11.1

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points