3 Replies Latest reply: Feb 8, 2013 5:49 AM by sayak RSS

    Spaces getting trimmed in presentation layer


      I am observing that the trailing spaces for the values of a field in the Physical layer are getting trimmed when I am using that field from presentation layer in Prompt/Report. For example, if the value is *'abcd '* in Physical layer, it is becoming *'abcd'* in presentation layer. Is this default behavior of OBIEE and can I change this so that the values will be picked as it is from Physical layer ?

      I am using OBIEE and the datatype of the field in Physical layer as well as database (Teradata) is char(40).
        • 1. Re: Spaces getting trimmed in presentation layer
          I would suggest adding Right Padding to the column values in the Results tab if there is only formatting significance to your requirement. If there is other significance, please explain so someone can better assist you.

          Please award points if helpful/correct.
          • 2. Re: Spaces getting trimmed in presentation layer
            I think I could not clarify my concern. Apologies for that. We do not have any formatting issue. We are using the field in a Prompt with operator as 'is equal to/is in'. So when the query gets formed, the where clause is coming as -

            field _name = 'abcd'

            whereas we want it to be

            field_name = 'abcd '

            Because in the database our value is 'abcd ',as the datatype is char.

            We could find a resolution to use 'Contains any' operator instead. But there are hundreds of reports using this field in prompt. Also there is some reason the application do not want to change the datatype in databse to varchar. I needed to know if somehow we can retain the blank spaces in presentation layer.
            • 3. Re: Spaces getting trimmed in presentation layer
              Hi ,

              I think "space_supported" (by default its unchecked)is the parameter u r looking for .(physical layer - > DB features)