1 Reply Latest reply: Feb 8, 2013 4:21 AM by kvlek RSS

    Apex Version 4.2: Why doesn't the session timeout parameter settings work?

    977701
      Prior to an upgrade to Apex Version 4.2.0.00.27, we ran Apex Version 4.1 in our environment. This is on a platform using Oracle Database Enterprise Edition 11g R2 on Windows Server 2008. The session timeout parameters (set for a single application using "Shared Components" -> "Security Attributes") were set to the following:

      Maximum Session Time: 1 day
      Maximum Session Idle Time: 8 hours

      This worked with no problems in Apex 4.1; our user would leave a data entry form open for several hours, complete the data entry then submit the page. Now, with the upgrade to Apex 4.2, doing the same thing causes the system to redirect to the login page and aborting any edits or new data entered into the form previously.

      I have tried to set both session parameters to ZERO (0) which is what the documentation explains is the equivallent to "no timeout" but that didn't work as well.

      I have reset the session control parameters to what they were before the upgrade and my session times out before the time values I set. (on the version 4.2 upgraded instance).

      Why was the session timeout parameters I set ignored by the system? Can anyone else out there confirm/repeat the problem I observed?