1 Reply Latest reply: Feb 8, 2013 8:21 AM by ShaunSmith RSS

    TopLink Grid compatibility with EclipseLink >= 2.4

    jlamande
      Hi,

      EclipseLink 2.4 has been released since summer 2012.
      TopLink 12c (12.1.1), embedding toplink Grid, is not compatible with this version (internal APIs of EclipseLink have changed and broken compatibility).
      Does someone know when a new TopLink release compatible with at least the 2.4 will be available ? Is this programmed ?

      Thx
        • 1. Re: TopLink Grid compatibility with EclipseLink >= 2.4
          ShaunSmith
          The upcoming 12.1.2 release of TopLink will include EclipseLink 2.4. As you know, TopLink Grid is tightly coupled to the specific release of EclipseLink that it's shipped with due to API changes in EclipseLink. So you do need to wait for TopLink 12.1.2 if you want to use EclipseLink 2.4 with TLG.

          However, if you have a specific EclipseLink bug that you need a fix for please file an SR with Oracle support as it may be possible to backport to the release you're running on.

          --Shaun