3 Replies Latest reply: Feb 8, 2013 3:23 PM by EdInWisconsin RSS

    Java 7 Support?

      Management is asking when apps can be upgraded to Java 7 since support is end of life pretty much now for Java 6.
      We are using ADF 11.1.2 and I can't find clear information on whether that version of ADF/Weblogic is certified with Java 7. I don't care so much about the IDE as about the runtime components.
      There is a large spreadsheet for the 11gR1 but not 11gR2 at this site: http://www.oracle.com/technetwork/middleware/ias/downloads/fusion-certification-100350.html

      Does anyone know where I can find information on 11gR2 and Java 7?

        • 1. Re: Java 7 Support?
          Timo Hahn
          This is the certification document for 11g r2

          • 2. Re: Java 7 Support?
            Frédéric Desbiens-Oracle

            The certification information for 11.1.2 is here: http://www.oracle.com/technetwork/developer-tools/jdev/jdev11gr2-cert-405181.html

            What this page doesn't tell you is that WebLogic 10.3.6 already supports Java SE 7. You can run ADF (PS5) and ADF on it with a Java 7 vm (as mentioned in the spreadsheet for 11gR1). If all you care about is runtime, then you can already go forward.

            The next releases of JDeveloper 11gR1 ( and 11gR2 ( will be certified for use under Java 7.

            Best Regards,

            • 3. Re: Java 7 Support?
              Thanks. I find it all rather cryptic. I guess the part I missed is that ADF 11gR2 runs on Weblogic 11gR1 and that's why there was no spreadsheet for ADF support on Weblogic 11gR2.
              We're still on and 10.3.5 so I guess we need to upgrade to and 10.3.6.